summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-10-21 22:11:28 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:45:25 -0500
commit1cce28235dda2eb85ab8e4e2f813ac901666e4a3 (patch)
tree67f30645d079ecd2cca07aacd8b1a5ca56003db5 /gnu/packages/golang.scm
parent992d69b1e76dfc5b342176bb15437ac2f3690ea9 (diff)
gnu: Add go-github-com-onsi-gomega.
* gnu/packages/golang.scm (go-github-com-onsi-gomega): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e7a6b00bd9..d2357e4690 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11244,6 +11244,37 @@ serialiser for Go.")
library bevacqua/fuzzysearch.")
(license license:expat)))
+(define-public go-github-com-onsi-gomega
+ (package
+ (name "go-github-com-onsi-gomega")
+ (version "1.19.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/onsi/gomega")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "092phwk97sk4sv0nbx5pfhqs6x3x1lnrjwyda1m6b6zwrfmq5c6i"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/onsi/gomega"
+ ;; Unless we disable the tests, we have a circular dependency on
+ ;; ginkgo/v2.
+ #:tests? #f))
+ (propagated-inputs (list go-github-com-golang-protobuf-proto
+ go-golang-org-x-net
+ go-golang-org-x-sys
+ go-golang-org-x-text
+ go-google-golang-org-protobuf
+ go-gopkg-in-yaml-v2))
+ (home-page "https://github.com/onsi/gomega")
+ (synopsis "Matcher library for Ginkgo")
+ (description
+ "Gomega is the preferred matcher library for the Ginkgo test framework.")
+ (license license:expat)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar