summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2023-01-17 18:44:59 -0700
committerChristopher Baines <mail@cbaines.net>2023-02-07 00:05:53 +0100
commit502f7ed25c86b1037ba51fe419a6e172d6fda94e (patch)
treee164f20307b90349f77c9bcc758cd523e450e08c /gnu/packages/golang.scm
parent7938d68b6b2a804b48ab6799eab53630399f9c88 (diff)
gnu: Add misspell.
* gnu/packages/golang.scm (misspell): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 55d8794a5b..c791deac03 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4821,6 +4821,37 @@ Looks for an identical word on a list of words, if none is found, look for a
similar word.")
(license license:expat))))
+(define-public misspell
+ (package
+ (name "misspell")
+ (version "0.3.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/client9/misspell")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vwf33wsc4la25zk9nylpbp9px3svlmldkm0bha4hp56jws4q9cs"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/client9/misspell"
+ #:phases (modify-phases %standard-phases
+ (replace 'build
+ (lambda arguments
+ (apply (assoc-ref %standard-phases
+ 'build)
+ `(,@arguments #:import-path
+ "github.com/client9/misspell/cmd/misspell")))))))
+ (home-page "https://github.com/client9/misspell")
+ (synopsis "Correct commonly misspelled English words in source files")
+ (description
+ "misspell assists with correcting commonly misspelled English words in
+source files. A neutral variety of English is used by default, but a US or UK
+locale can be selected.")
+ (license license:expat)))
+
(define-public go-github-com-stevedonovan-luar
(let ((commit "22d247e5366095f491cd83edf779ee99a78f5ead")
(revision "0"))