summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-23 14:27:45 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 11:04:19 -0400
commit6265c972beaf04cbcfee141721d4c1b03b2f78c6 (patch)
tree98d070b10d65a3b9cff29e7c17d589f8ae018db3 /gnu/packages/golang.scm
parent95a24214d37fc6a7d965c46539f0b0b439975fb6 (diff)
gnu: Add go-github-com-xeipuuv-gojsonpointer.
* gnu/packages/golang.scm (go-github-com-xeipuuv-gojsonpointer): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 435c9f4c4e..a474782beb 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12894,6 +12894,31 @@ reflect.DeepEqual but returns a list of differences. This is helpful
when comparing complex types like structures and maps.")
(license license:expat)))
+(define-public go-github-com-xeipuuv-gojsonpointer
+ (let ((commit "4e3ac2762d5f479393488629ee9370b50873b3a6")
+ (revision "0"))
+ (package
+ (name "go-github-com-xeipuuv-gojsonpointer")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xeipuuv/gojsonpointer")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13y6iq2nzf9z4ls66bfgnnamj2m3438absmbpqry64bpwjfbsi9q"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/xeipuuv/gojsonpointer"))
+ (home-page "https://github.com/xeipuuv/gojsonpointer")
+ (synopsis "Implementation of JSON Pointer for Go")
+ (description
+ "This package provides an implementation of JSON Pointer for the Go
+programming language.")
+ (license license:asl2.0))))
+
(define-public go-github-com-niemeyer-pretty
(package
(name "go-github-com-niemeyer-pretty")