summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-06-05 21:52:22 +0800
committerLudovic Courtès <ludo@gnu.org>2023-07-01 23:38:27 +0200
commit74adc157874fa1f289e8abc01800e04c3d391d7d (patch)
tree97088f7bff3af4063234808d1e1325c267a507db /gnu/packages/golang.scm
parent8e755ae0773dba824513ed6eb84cb41433a5fba8 (diff)
gnu: Add go-github-com-rylans-getlang.
* gnu/packages/golang.scm (go-github-com-rylans-getlang): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0056c85296..2eabb1ed11 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -13038,6 +13038,32 @@ algorithm originally designed for use in Netscape Mail 2.0 for Go.")
of the current user.")
(license license:expat)))
+(define-public go-github-com-rylans-getlang
+ (package
+ (name "go-github-com-rylans-getlang")
+ (version "0.0.0-20201227074721-9e7f44ff8aa0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rylans/getlang")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yf698h21j88d7d9wkzq69cfd7vs1mfp96nhb83lx6hhh7rfvb92"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/rylans/getlang"))
+ (propagated-inputs
+ (list go-golang-org-x-text))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/rylans/getlang")
+ (synopsis "Natural language detection package in pure Go")
+ (description
+ "This package provides fast natural language detection in Go.")
+ (license license:expat)))
+
(define-public go-github-com-kyoh86-xdg
(package
(name "go-github-com-kyoh86-xdg")