summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-06-05 21:52:20 +0800
committerLudovic Courtès <ludo@gnu.org>2023-07-01 23:38:27 +0200
commit7c9265c46f746eff42c14639a37f0e6471b209a5 (patch)
treed8f8c9f099fa7fa3125ed971dc90510fc1d4d3cc /gnu/packages/golang.scm
parentae93b542b22a0da491479132f658ca30ffdc9b24 (diff)
gnu: Add go-github-com-go-telegram-bot-api-telegram-bot-api.
* gnu/packages/golang.scm (go-github-com-go-telegram-bot-api-telegram-bot-api): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 84c0c577fb..581420a53f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10757,6 +10757,31 @@ modifying them.")
parsers, and related tools.")
(license license:expat))))
+(define-public go-github-com-go-telegram-bot-api-telegram-bot-api
+ (package
+ (name "go-github-com-go-telegram-bot-api-telegram-bot-api")
+ (version "4.6.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-telegram-bot-api/telegram-bot-api")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1x6j0k3aiicsr8l53na99ci10zm3qpn2syz4f60fzh164w5k1l7w"))))
+ (build-system go-build-system)
+ (home-page "https://go-telegram-bot-api.dev/")
+ (arguments
+ (list #:tests? #f ; Upstream tests are broken.
+ #:import-path "github.com/go-telegram-bot-api/telegram-bot-api"))
+ (propagated-inputs
+ (list go-github-com-technoweenie-multipartstreamer))
+ (synopsis "Golang bindings for the Telegram Bot API")
+ (description
+ "This package provides Golang bindings for the Telegram Bot API.")
+ (license license:expat)))
+
(define-public go-github.com-ulikunitz-xz
(package
(name "go-github.com-ulikunitz-xz")