summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSarah Morgensen <iskarian@mgsn.dev>2024-02-15 21:06:54 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-15 21:06:54 +0000
commit839039c0b5afa8f200c643c6abb7ec33c6bc5151 (patch)
tree5c325c481e738cf801750776bfbba1c62e1f67d3 /gnu/packages/golang.scm
parent8c9bc0e710bbb503d9dc6a9c135876b4d8bdbc2a (diff)
gnu: go-github-com-mattn-go-shellwords: Fix sh path.
* gnu/packages/golang.scm (go-github-com-mattn-go-shellwords) [arguments] <#:phases> {patch-sh-path}: New phase. Co-authored-by: Sharlatan Hellseher <sharlatanus@mgail.com> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I9e8051a502471ff1ade2517c9d839af765de3a25
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 7 insertions, 17 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4593c4ee48..4b87183f16 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6073,24 +6073,14 @@ exploration and data entry.")
(build-system go-build-system)
(arguments
`(#:import-path "github.com/mattn/go-shellwords"
- ;; TODO: can't make homeless-shelter:
- ;; go: disabling cache (/homeless-shelter/.cache/go-build) due to
- ;; initialization failure: mkdir /homeless-shelter: permission denied
-
- ;; This doesn't seem to work:
-
- ;; #:phases
- ;; (modify-phases %standard-phases
- ;; (replace 'check
- ;; (lambda* (#:key import-path #:allow-other-keys)
- ;; (setenv "HOME" "/tmp")
- ;; (invoke "go" "test" import-path))))
-
- ;; TODO: There are also a couple of tests that have stymied Debian in
- ;; the past. They seem to work when run locally.
-
#:tests? #f
- ))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-sh-path
+ (lambda* (#:key import-path #:allow-other-keys)
+ (substitute* (string-append
+ "src/" import-path "/util_posix.go")
+ (("/bin/sh") (which "sh"))))))))
(home-page "https://github.com/mattn/go-shellwords")
(synopsis "Parse lines into shell words")
(description "This package parses text into shell arguments. Based on