summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-29 01:20:02 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 14:17:34 +0000
commitaf0b968955c22213f5e55667bcb8b67fda8cc64a (patch)
treea3607dd5aa3fc4a7ff882cb433fae9099f4cf627 /gnu/packages/golang.scm
parent8bd9ca475e863f0c79ef577a5d7ef45e875b4a70 (diff)
gnu: go-github-com-goccy-yaml: Update to 1.11.3.
* gnu/packages/golang.scm (go-github-com-goccy-yaml): Update to 1.11.3. [arguments] <#:go>: Use go-1.18. [native-inputs]: Add go-github-com-google-go-cmp-cmp. Replace go-gopkg-in-go-playground-validator-v9 with go-github-com-go-playground-validator-v10. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Ic037a61fe627411d380887d7a9f9962abf6ca004
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7f6b8769a4..b40c41aab8 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8900,7 +8900,7 @@ modifying them.")
(define-public go-github-com-goccy-yaml
(package
(name "go-github-com-goccy-yaml")
- (version "1.8.0")
+ (version "1.11.3")
(home-page "https://github.com/goccy/go-yaml")
(source
(origin
@@ -8910,10 +8910,11 @@ modifying them.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1nps58dwkd915mx35h5f0dc05b880b4fdl6dcjxpfmmbzyinvg38"))))
+ (base32 "1rm2rfnlvv704zkb1mnjqv5xx32vfkzv7r2kc8if6gr9ryb7hmbf"))))
(build-system go-build-system)
(arguments
(list
+ #:go go-1.18
#:import-path "github.com/goccy/go-yaml"
#:phases #~(modify-phases %standard-phases
(add-after 'unpack 'remove-benchmarks
@@ -8923,7 +8924,8 @@ modifying them.")
(propagated-inputs
(list go-github-com-fatih-color go-golang-org-x-xerrors))
(native-inputs
- (list go-gopkg-in-go-playground-validator-v9))
+ (list go-github-com-go-playground-validator-v10
+ go-github-com-google-go-cmp-cmp))
(synopsis "YAML support for the Go language")
(description
"This package provides features beyond the