summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-29 01:19:49 +0800
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-16 14:17:32 +0000
commitb5e008d04cde16453e98c2afaa8087f02a5db79b (patch)
tree6081bcf14a2e6f3930aff8b59aec3ce759137d20 /gnu/packages/golang.scm
parent5a09b0447bd4fb1661314263415818cc0bae1053 (diff)
gnu: go-github-com-alecthomas-repr: Update to 0.3.0.
* gnu/packages/golang.scm (go-github-com-alecthomas-repr): Update to 0.3.0. [arguments] <#:go>: Use go-1.18. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I3fe2baeff3cd4736688552029cf3902da01a415a
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm45
1 files changed, 22 insertions, 23 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7cc532d223..7dee2adefc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7551,30 +7551,29 @@ stripped.")
(license license:expat)))
(define-public go-github-com-alecthomas-repr
- (let ((commit "4184120f674c8860a5b48142509a2411a0a1766f")
- (revision "1"))
- (package
- (name "go-github-com-alecthomas-repr")
- (version (git-version "0.0.1" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alecthomas/repr")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1z0gdkjryxg1ps5fh4ybzip27g9lzdldz4hxqp5j7s2frbzaa9s7"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/alecthomas/repr"))
- (native-inputs
- (list go-github-com-stretchr-testify))
- (home-page "https://github.com/alecthomas/repr/")
- (synopsis "Represent Go values in an almost direct form")
- (description "This package attempts to represent Go values in a form that
+ (package
+ (name "go-github-com-alecthomas-repr")
+ (version "0.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alecthomas/repr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zq30b36vvg4kzxkff64gjwvcjaw0d13dqzfjfai66hkh3ijdzwl"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:go ,go-1.18
+ #:import-path "github.com/alecthomas/repr"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/alecthomas/repr/")
+ (synopsis "Represent Go values in an almost direct form")
+ (description "This package attempts to represent Go values in a form that
can be used almost directly in Go source code.")
- (license license:expat))))
+ (license license:expat)))
(define-public go-github-com-sergi-go-diff
(package