summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-06-05 21:52:16 +0800
committerLudovic Courtès <ludo@gnu.org>2023-07-01 23:38:26 +0200
commitb7708699d93d2104f9fd949e97c5757ed9eb5c39 (patch)
tree6be621e441767d2906bc4fb8c1244ccaffa32f0a /gnu/packages/golang.scm
parentf52a41ab97ab4138f04b893c3d234cc364364bfc (diff)
gnu: Add go-github-com-tdewolff-test.
* gnu/packages/golang.scm (go-github-com-tdewolff-test): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ad3e7c875e..471a150366 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3384,6 +3384,29 @@ per-goroutine.")
(description "The @code{walker} function is a faster, parallel version, of
@code{filepath.Walk}")))
+(define-public go-github-com-tdewolff-test
+ (package
+ (name "go-github-com-tdewolff-test")
+ (version "1.0.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tdewolff/test")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10myz3zdkqmx37cvj507h7l2ncb0rq9shqvz9ggq1swijbsvazff"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/tdewolff/test"))
+ (home-page "https://github.com/tdewolff/test")
+ (synopsis "Go test helper functions")
+ (description
+ "This package implements a few functions that are useful for io testing,
+such as readers and writers that fail after N consecutive reads/writes.")
+ (license license:expat)))
+
(define-public go-github-com-tj-docopt
(package
(name "go-github-com-tj-docopt")