summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 21:32:33 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:28:30 +0000
commitc3992c8871c6bef554e180ab0ecdb786a9595207 (patch)
treee1520a6b519a7d7975997fe73f51aa0c2317b63d /gnu/packages/golang.scm
parentd3bc9e73e5fdee97244069dadaa75b5109236359 (diff)
gnu: go-go-uber-org-zap: Move to golang-xyz.
* gnu/packages/golang.scm (go-go-uber-org-zap): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/radio.scm: Add (gnu packages golang-xyz) module. Change-Id: Id4de6cb4714b9b28e43e5aecabf5b32684f1a370
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6d19bf4f70..fbf6b4c349 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9319,36 +9319,6 @@ be used as both a binary and a library.")
(native-inputs '())
(inputs '())))
-(define-public go-go-uber-org-zap
- (package
- (name "go-go-uber-org-zap")
- (version "1.24.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/uber-go/zap")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0lzbbs87fvixzbyv4wpl3s70vm2m0jz2jgdvrviiksc2al451qgs"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "go.uber.org/zap"
- #:tests? #f)) ; TODO: Fix tests
- (native-inputs
- (list go-github-com-stretchr-testify go-golang-org-x-lint
- go-honnef-co-go-tools))
- (propagated-inputs
- (list go-github-com-pkg-errors go-go-uber-org-atomic
- go-go-uber-org-multierr go-gopkg-in-yaml-v2))
- (home-page "https://go.uber.org/zap")
- (synopsis "Logging library for Go")
- (description
- "This package provides a library for fast, structured, leveled logging in
-Go.")
- (license license:expat)))
-
(define-public go-github-com-davecgh-go-xdr
(package
(name "go-github-com-davecgh-go-xdr")