summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 09:02:44 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:43 +0100
commitc73f70d3d50db50c6dcd6a5fd55b448bc7e36fd7 (patch)
treebcdc5ce09a3721af20f0a49b79739e625e862956 /gnu/packages/golang.scm
parent5abebf71e91d16947d1ade8d4b97a76fc06e2be3 (diff)
gnu: go-github-com-mattn-go-isatty: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-mattn-go-isatty): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/music.scm: Add (gnu packages golang-xyz) module. Change-Id: Ibbab55ed60afdd5513f91dde93550b2eff7a622c
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a8f830e1d9..ed79a8b692 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4351,32 +4351,6 @@ The yaml package supports most of YAML 1.2, but preserves some behavior from
(description "This package provides a Golang Matrix client.")
(license license:asl2.0)))
-(define-public go-github-com-mattn-go-isatty
- (package
- (name "go-github-com-mattn-go-isatty")
- (version "0.0.20")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mattn/go-isatty")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0g63n9wpb991qnq9mn2kvd8jk1glrp6gnd851kvwz2wmzdkggiga"))))
- (build-system go-build-system)
- (propagated-inputs
- (list go-golang-org-x-sys))
- (arguments
- '(#:import-path "github.com/mattn/go-isatty"))
- (home-page "https://github.com/mattn/go-isatty")
- (synopsis "Provide @code{isatty} for Golang")
- (description "This package provides @code{isatty}, a Go module that can
-tell you whether a file descriptor points to a terminal and the type of the
-terminal.")
- (license license:expat)))
-
(define-public go-github-com-mattn-go-colorable
(package
(name "go-github-com-mattn-go-colorable")