summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-09-01 20:58:11 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-04 22:46:06 -0400
commitc7a881fc5e1d1280506eb29a1f186a67da8fefdd (patch)
tree33bad70b72f2decf738c9fb9d30e7d7669054d1f /gnu/packages/golang.scm
parent452f36c6149242157d685d40a30c9b47fd30a942 (diff)
gnu: Add go-github-com-bitly-timer-metrics.
* gnu/packages/golang.scm (go-github-com-bitly-timer-metrics): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7a2e87e2ed..224b47f993 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2138,6 +2138,29 @@ multiple hosts from your Go application. Host selection can operate in round
robin or epsilon greedy mode, and unresponsive hosts are avoided.")
(license license:expat)))
+(define-public go-github-com-bitly-timer-metrics
+ (package
+ (name "go-github-com-bitly-timer-metrics")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bitly/timer_metrics")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "02fhx8hx8126m2cgxw9fm8q2401r7zfann8b5zy5yyark1sgkrb4"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/bitly/timer_metrics"))
+ (home-page "https://github.com/bitly/timer_metrics")
+ (synopsis "Capture timings and enable periodic metrics every @var{n} events")
+ (description
+ "This package provides an efficient way to capture timing information and
+periodically output metrics")
+ (license license:expat)))
+
(define-public go-github-com-blanu-dust
(package
(name "go-github-com-blanu-dust")