summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2023-01-17 18:44:52 -0700
committerChristopher Baines <mail@cbaines.net>2023-02-07 00:05:52 +0100
commitedace44c4ad0350148e0a7264fb975685d189cf5 (patch)
tree35403d045a73a340a4c9cb4b244dc4967ec4b91f /gnu/packages/golang.scm
parented4effffd24baf7b1f5e5a3f8d064e425ed529d7 (diff)
gnu: go-github-com-google-go-cmp-cmp: Update to 0.5.9.
* gnu/packages/golang.scm (go-github-com-google-go-cmp-cmp): Update to 0.5.9. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4e88ceec0c..c6bd9fa225 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7024,28 +7024,27 @@ colorized or SGR defined output to the standard output.")
(define-public go-github-com-google-go-cmp-cmp
(package
(name "go-github-com-google-go-cmp-cmp")
- (version "0.5.2")
+ (version "0.5.9")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/google/go-cmp")
- (commit (string-append "v" version))))
+ (url "https://github.com/google/go-cmp")
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0qchy411jm9q2l9mf7x3ry2ycaqp9xdhf2nx14qrpzcxfigv2705"))))
+ "0a13m7l1jrysa7mrlmra8y7n83zcnb23yjyg3a609p8i9lxkh1wm"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/google/go-cmp/cmp"
#:unpack-path "github.com/google/go-cmp"))
- (propagated-inputs
- (list go-golang-org-x-xerrors))
(synopsis "Determine equality of values in Go")
- (description "This package provides a more powerful and safer
-alternative to @code{reflect.DeepEqual} for comparing whether two values
-are semantically equal in Go (for writing tests).")
- (home-page "https://godoc.org/github.com/google/go-cmp/cmp")
- (license license:asl2.0)))
+ (description
+ "This package is intended to be a more powerful and safer
+alternative to @@code{reflect.DeepEqual} for comparing whether two values are
+semantically equal.")
+ (home-page "https://github.com/google/go-cmp")
+ (license license:bsd-3)))
(define-public go-github-com-google-uuid
(package