summaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-06-05 21:52:13 +0800
committerLudovic Courtès <ludo@gnu.org>2023-07-01 23:38:26 +0200
commitf69e7eaf737200d498a48c21406ca81bc4aa442b (patch)
tree4864eb09187441a3d3dbcd88a3206edb2841f020 /gnu/packages/golang.scm
parenta3363e50cf785817268c7b63a2c434c18d13329e (diff)
gnu: Add go-github-com-pquerna-cachecontrol.
* gnu/packages/golang.scm (go-github-com-pquerna-cachecontrol): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 18d588c018..a3794f9474 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3646,6 +3646,31 @@ developed by the Go team. It provides IDE features to any LSP-compatible
editor.")
(license license:bsd-3)))
+(define-public go-github-com-pquerna-cachecontrol
+ (package
+ (name "go-github-com-pquerna-cachecontrol")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pquerna/cachecontrol")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0d5zgv2w0sinh9m41pw3n015zzyabk7awgwwga7nmhjz452c9r5n"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/pquerna/cachecontrol"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/pquerna/cachecontrol")
+ (synopsis "Golang HTTP Cache-Control Parser and Interpretation")
+ (description
+ "This package implements RFC 7234 Hypertext Transfer Protocol (HTTP/1.1):
+Caching.")
+ (license license:asl2.0)))
+
(define-public go-github-com-protonmail-go-crypto
(package
(name "go-github-com-protonmail-go-crypto")