summaryrefslogtreecommitdiff
path: root/gnu/packages/graph.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2023-08-03 17:59:49 +0000
committerChristopher Baines <mail@cbaines.net>2023-08-27 19:10:23 +0100
commit6482f61a0cf65bd32be0a9bbd0ce5c349b28c0c0 (patch)
tree88583113de76d626965e2f0509dc20101849a8d0 /gnu/packages/graph.scm
parentbe2786144cf8333ab3992423962d15a998a942bd (diff)
gnu: python-graph-tool: Update to 2.57.
* gnu/packages/graph.scm (python-graph-tool): Update to 2.57. [propagated-inputs]: Add python-zstandard. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/graph.scm')
-rw-r--r--gnu/packages/graph.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 5510828edf..45a591b9f3 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -57,6 +57,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
+ #:use-module (gnu packages python-compression)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
@@ -624,7 +625,7 @@ transformed into common image formats for display or printing.")
(define-public python-graph-tool
(package
(name "python-graph-tool")
- (version "2.46")
+ (version "2.57")
(source (origin
(method url-fetch)
(uri (string-append
@@ -632,7 +633,7 @@ transformed into common image formats for display or printing.")
version ".tar.bz2"))
(sha256
(base32
- "0x9jgnq9xcja3q954y7nhdzd374p4h203pymxh51b6lqqbq0hm9h"))))
+ "0wmvzx509lvigja6cfxh45r4b7wns64vmik0x4rz4y4fnxrhw2m2"))))
(build-system gnu-build-system)
(arguments
`(#:imported-modules (,@%gnu-build-system-modules
@@ -656,7 +657,11 @@ transformed into common image formats for display or printing.")
python-wrapper
sparsehash))
(propagated-inputs
- (list python-matplotlib python-numpy python-pycairo python-scipy))
+ (list python-matplotlib
+ python-numpy
+ python-pycairo
+ python-scipy
+ python-zstandard))
(synopsis "Manipulate and analyze graphs with Python efficiently")
(description "Graph-tool is an efficient Python module for manipulation
and statistical analysis of graphs (a.k.a. networks). Contrary to most other