summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-08 09:06:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-08 09:06:14 +0200
commit1c94392a13cbdf87e03a644633eb775bf45694a1 (patch)
tree74f11038dfc5f9d9db06660b1087253b28c5434f /gnu/packages/graphics.scm
parentdd87bbb2b78b279248aaff15c0706fcd6d8cd7bb (diff)
parent9d25ee30b188f9202cc14f7cd25ba8a1c3ec1a72 (diff)
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm26
1 files changed, 0 insertions, 26 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index c3b55f695a..dbb489452e 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1289,32 +1289,6 @@ virtual reality, scientific visualization and modeling.")
;; LGPL 2.1, but with 4 exceptions. This version is called OSGPL.
(license license:lgpl2.1)))
-;; We need this for simgear
-(define-public openscenegraph-3.4
- (package (inherit openscenegraph)
- (name "openscenegraph")
- (version "3.4.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/openscenegraph/OpenSceneGraph")
- (commit (string-append "OpenSceneGraph-" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1fbzg1ihjpxk6smlq80p3h3ggllbr16ihd2fxpfwzam8yr8yxip9"))))
- (arguments
- (substitute-keyword-arguments (package-arguments openscenegraph)
- ((#:configure-flags flags)
- `(cons
- ;; The jpeg plugin requires conversion between integers and booleans
- "-DCMAKE_CXX_FLAGS=-fpermissive"
- ,flags))))
- (inputs
- `(("libjpeg" ,libjpeg-turbo)
- ,@(package-inputs openscenegraph)))))
-
(define-public gr-framework
(package
(name "gr-framework")