summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2022-03-15 22:40:27 +0800
committerLudovic Courtès <ludo@gnu.org>2022-04-04 22:58:02 +0200
commit095c609dfde26730ac18b497f2deca4d78a4c4df (patch)
treef32af045866f38c199ca233ef6a23a822bdc001d /gnu/packages/gtk.scm
parent287b98031f55cbc3a89ad0a0ae99cfa28eb153f4 (diff)
gnu: gtkmm: Update to 4.6.1.
* gnu/packages/gtk.scm (gtkmm): Update to 4.6.1. [propagated-inputs]: Remove atkmm because it's no longer needed. * gnu/packages/gtk.scm (pangomm): Update to 2.50.0. [propagated-inputs]: Replace 'pango' with 'pango-next'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a45467fd6f..96297535ce 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1627,7 +1627,7 @@ library.")
(define-public pangomm
(package
(name "pangomm")
- (version "2.48.0")
+ (version "2.50.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1635,7 +1635,7 @@ library.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0y2vyp6azvhrii6rzs89kr08wg8z1p562awyr812131zqdsd83ly"))))
+ "0nrvvf1fyzlimh7rvxcblnrvn2l9rz8mpn2iwzlzr6kv05zafym2"))))
(build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
@@ -1664,7 +1664,7 @@ library.")
("python" ,python)
("xsltproc" ,libxslt)))
(propagated-inputs
- (list cairo cairomm glibmm pango))
+ (list cairo cairomm glibmm pango-next))
(home-page "https://pango.gnome.org//")
(synopsis "C++ interface to the Pango text rendering library")
(description
@@ -1760,7 +1760,7 @@ library.")
(define-public gtkmm
(package
(name "gtkmm")
- (version "4.4.0")
+ (version "4.6.1")
(source
(origin
(method url-fetch)
@@ -1769,7 +1769,7 @@ library.")
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "1nhdf1s437k41af6frbqw2sky46qci0hgkg9h86a9rlnc0r69d1f"))))
+ (base32 "1q6iycd7jfbn6rp4sq6r7ndm96dc21inq8mq1d9xsky6kv5gwphd"))))
(build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
@@ -1809,7 +1809,7 @@ library.")
("xsltproc" ,libxslt)
("xorg-server" ,xorg-server-for-tests)))
(propagated-inputs
- (list atkmm cairomm glibmm gtk pangomm))
+ (list cairomm glibmm gtk pangomm))
(synopsis "C++ Interfaces for GTK+ and GNOME")
(description "GTKmm is the official C++ interface for the popular GUI
library GTK+. Highlights include typesafe callbacks, and a comprehensive set