summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-06-09 09:44:44 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-19 11:14:10 +0200
commit3d9fddb2683790df26c53e18d4ff9468442e2368 (patch)
tree0226d7328671ebe4def35f6af0000b137e426269 /gnu/packages/gtk.scm
parentb030bc0c2788648e53b4dc5dd764ab120bd4d3a0 (diff)
gnu: graphene: Update package definition.
* gnu/packages/gtk.scm (graphene): Update package definition. [source]<origin>[method]: Change from url-fetch to git-fetch. [uri]: Add git-reference. [sha256]: Modify base32. [arguments]<#:glib-or-gtk?>: New argument. [native-inputs]: Add git-minimal and mutest. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm38
1 files changed, 23 insertions, 15 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 3574d7a3f2..9958fbadf1 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -84,6 +84,7 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages guile-xyz)
#:use-module (gnu packages cups)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (gnu packages xdisorg)
@@ -1864,27 +1865,34 @@ Parcellite and adds bugfixes and features.")
(package
(name "graphene")
(version "1.10.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/ebassi/graphene/releases/"
- "download/" version
- "/graphene-" version ".tar.xz"))
- (sha256
- (base32 "16b4hz73bnrgv5v8n96dczkd6xp9qc06lrl43zln3jnl3psrfva0"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/ebassi/graphene.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14a0j1rvjlc7yhfdmhmckdmkzy4ch61qbzywdlw1xv58h23wx29p"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags '("-Dinstalled_tests=false")))
+ `(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
+ #:configure-flags
+ (list
+ "-Dinstalled_tests=false")))
(native-inputs
- `(("gobject-introspection" ,gobject-introspection)
+ `(("git" ,git-minimal)
+ ("gobject-introspection" ,gobject-introspection)
+ ("mutest" ,mutest)
("pkg-config" ,pkg-config)))
(inputs
- `(("python" ,python)
- ("glib" ,glib)))
- (home-page "https://ebassi.github.io/graphene/")
+ `(("glib" ,glib)
+ ("python" ,python)))
(synopsis "Thin layer of graphic data types")
- (description "This library provides graphic types and their relative API;
-it does not deal with windowing system surfaces, drawing, scene graphs, or
-input.")
+ (description "Graphene provides graphic types and their relative API; it
+does not deal with windowing system surfaces, drawing, scene graphs, or input.")
+ (home-page "https://ebassi.github.io/graphene/")
(license license:expat)))
(define-public spread-sheet-widget