summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2024-04-09 16:44:22 +0100
committerChristopher Baines <mail@cbaines.net>2024-04-09 16:46:34 +0100
commit6cae1db889f62051580d5a365f62585412a53a8c (patch)
tree4d3db074d50ca3e2109cced17bec77f207a0c1fd /gnu/packages/gtk.scm
parent410e699e0933653e69d03a4cdadf11854c6723f4 (diff)
parent35e1d9247e39f3c91512cf3d9ef1467962389e35 (diff)
Merge remote-tracking branch 'savannah/master' into mesa-updates
Change-Id: Iad185e2ced97067b3dff8fd722435a6c5e2c00e5
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm18
1 files changed, 6 insertions, 12 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b463e15d48..b0098e780e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1166,23 +1166,17 @@ application suites.")
"--no-suite=failing"
"--no-suite=flaky"
"--no-suite=headless" ; requires mutter…
- "--no-suite=gsk-compare-broadway")
+ "--no-suite=gsk-compare-broadway"
+ ;; These seem to fail on aarch64, and Debian has
+ ;; also disabled these, see:
+ ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1050075
+ "--no-suite=wayland_failing"
+ "--no-suite=wayland_gles_failing")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file
(assoc-ref glib-or-gtk:%standard-phases
'generate-gdk-pixbuf-loaders-cache-file))
- #$@(if (target-aarch64?)
- #~((add-after 'unpack 'skip-failing-test
- (lambda _
- ;; MESA: error: ZINK: failed to load libvulkan.so.1
- ;; libEGL warning: egl: failed to create dri2 screen
- ;; MESA: error: ZINK: failed to load libvulkan.so.1
- ;; glx: failed to create drisw screen
- ;; failed to load driver: zink
- (substitute* "testsuite/gsk/meson.build"
- ((".*big-checkerboard-scaled-down2',\n") "")))))
- #~())
(add-after 'unpack 'patch-rst2man
(lambda _
(substitute* "docs/reference/gtk/meson.build"