summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-05-15 22:55:24 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-15 22:55:24 +0200
commit25487c3fe6a41dd62f6e53f256392224a3be2a08 (patch)
tree1051a1716d962ba0a7bbbf9dc8f7b67aa2674400 /gnu/packages/guile-xyz.scm
parent4a9597e4516ec5ca58df3e007fcd5ef1d3fd2e54 (diff)
parent46eac03e720e9b21d225e2ec1c41299c09202d18 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm81
1 files changed, 79 insertions, 2 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 7bbba8ff70..797210ee04 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -36,6 +36,8 @@
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
+;;; Copyright © 2021 Zelphir Kaltstahl <zelphirkaltstahl@posteo.de>
+;;; Copyright © 2021 Oleg Pykhalov <go.wigust@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -361,13 +363,13 @@ $(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)\n"))
dictionary and suggesting spelling corrections.")
(license license:gpl3+)))
-(define-public guile-bash
+(define-public guile2.0-bash
;; This project is currently retired. It was initially announced here:
;; <https://lists.gnu.org/archive/html/guile-user/2015-02/msg00003.html>.
(let ((commit "1eabc563ca5692b3e08d84f1f0e6fd2283284469")
(revision "0"))
(package
- (name "guile-bash")
+ (name "guile2.0-bash")
(version (string-append "0.1.6-" revision "." (string-take commit 7)))
(home-page
"https://anonscm.debian.org/cgit/users/kaction-guest/retired/dev.guile-bash.git")
@@ -430,6 +432,25 @@ enable -f ~/.guix-profile/lib/bash/libguile-bash.so scm
and then run @command{scm example.scm}.")
(license license:gpl3+))))
+(define-public guile-bash
+ (package
+ (inherit guile2.0-bash)
+ (name "guile-bash")
+ (inputs
+ `(("guile" ,guile-3.0-latest)
+ ,@(assoc-remove! (package-inputs guile2.0-bash) "guile")))
+ (arguments
+ `(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'install-guile
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (copy-recursively
+ (string-append (assoc-ref outputs "out")
+ (assoc-ref inputs "guile") "/share")
+ (string-append (assoc-ref outputs "out") "/share"))
+ #t)))
+ ,@(package-arguments guile2.0-bash)))))
+
(define-public guile-8sync
(package
(name "guile-8sync")
@@ -2106,6 +2127,38 @@ microAdapton. Both miniAdapton and microAdapton are designed to be easy to
understand, extend, and port to host languages other than Scheme.")
(license license:expat))))
+(define-public guile-raw-strings
+ (let ((commit "aa1cf783f2542811b473f797e12490920b779baa")
+ (revision "0"))
+ (package
+ (name "guile-raw-strings")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lloda/guile-raw-strings")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1r2gx86zw5hb6byllra3nap3fw9p7q7rvdmg6qn9myrdxyjpns3l"))))
+ (build-system guile-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'build 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "guile" "-L" "." "-s" "test.scm")))))))
+ (native-inputs
+ `(("guile" ,guile-3.0)))
+ (home-page "https://github.com/lloda/guile-raw-strings")
+ (synopsis "Guile reader extension for `raw strings'")
+ (description "This package provides A Guile reader extension for `raw
+strings', it lets you write verbatim strings without having to escape double
+quotes. ")
+ (license license:public-domain))))
+
(define-public guile-reader
(package
(name "guile-reader")
@@ -4665,3 +4718,27 @@ properties inspired by ghc-quickcheck. You can use it to express properties,
which functions should satisfy, as Scheme code and then check whether they hold
in a large number of randomly generated test cases.")
(license license:gpl3+)))
+
+(define-public guile-fslib
+ (package
+ (name "guile-fslib")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://notabug.org/ZelphirKaltstahl/guile-fslib/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "118d84p443w7hrslv8hjyhgws631ia08mggiyklkmk0b9plfdsvz"))))
+ (build-system guile-build-system)
+ (inputs
+ `(("guile" ,guile-3.0)))
+ (home-page "https://notabug.org/ZelphirKaltstahl/guile-fslib")
+ (synopsis "Helper functions for working with locations in file systems")
+ (description
+ "This package contains helper functions for working with file system
+locations.")
+ (license license:agpl3+)))