summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-12 14:33:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-12 14:36:44 +0300
commit322917aeb8e672c21378fd371a5cff4a9f0c2520 (patch)
tree70229faa39f14caa09b769153453c3898f64f7fc /gnu/packages/guile-xyz.scm
parent407f017663c97ebfe48e3cb304bf97bf2557f83f (diff)
parente1baf802ccd8af4f7b416b0987db706f2dbfc42f (diff)
Merge remote-tracking branch 'origin/master' into staging
Conflicts: gnu/packages/gnuzilla.scm gnu/packages/graphics.scm gnu/packages/gstreamer.scm gnu/packages/gtk.scm gnu/packages/kde-frameworks.scm gnu/packages/video.scm
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 2e7094cfff..2877b7d199 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4500,15 +4500,15 @@ tools.")
(define-public guile-eris
(package
(name "guile-eris")
- (version "0.2.0")
+ (version "1.0.0")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://inqlab.net/git/eris.git")
+ (url "https://codeberg.org/eris/guile-eris.git")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
- (sha256 (base32 "1ijglmwkdy1l87gj429qfjis0v8b1zlxhbyfhx5za8664h68nqka"))))
+ (sha256 (base32 "0d4wbjwwaxk0zn5gjhl86qhvk1aisgzp1vnvy4xbvrv5ydqpgyqm"))))
(build-system gnu-build-system)
(arguments '())
(native-inputs
@@ -4517,17 +4517,18 @@ tools.")
pkg-config
texinfo
;; test dependency
- guile-srfi-180))
+ guile-srfi-180
+ guile-quickcheck))
(inputs (list guile-3.0))
(propagated-inputs
(list guile-sodium))
(synopsis "Guile implementation of the Encoding for Robust Immutable Storage (ERIS)")
(description
- "Guile-ERIS is the reference implementation of the Encoding for Robust
-Immutable Storage (ERIS). ERIS allows arbitrary content to be encoded into
-uniformly sized, encrypted blocks that can be reassembled using a short
-read-capability.")
- (home-page "https://inqlab.net/git/eris.git")
+ "Guile-ERIS is a Guile implementation of the @url{http://purl.org/eris,
+Encoding for Robust Immutable Storage (ERIS)}. ERIS allows arbitrary content
+to be encoded into uniformly sized, encrypted blocks that can be reassembled
+using a short read-capability.")
+ (home-page "https://codeberg.org/eris/guile-eris")
(license license:gpl3+)))
(define-public guile-r6rs-protobuf