summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-06-17 04:50:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-17 04:52:22 +0200
commitbb6c8f207b43d7de8ef061edfaaa1c28e9c7bccb (patch)
tree80f17f71e3023abd2e92cb8ed4758d207b7b96fb /gnu/packages/guile-xyz.scm
parentd1a3a8e15ea3ae1648269b88de1665f4e87e0835 (diff)
gnu: guile-gi: Update to 0.0.2.
* gnu/packages/guile-xyz.scm (guile-gi): Update to 0.0.2. [source]: Fetch using url-fetch. [arguments]: Add make flags to remove unexpectedly passing test from XFAIL_TESTS. [native-inputs]: Remove autoconf, automake, and texinfo.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm67
1 files changed, 32 insertions, 35 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 6e19a38863..69fca334ca 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2247,43 +2247,40 @@ list of components. This module takes care of that for you.")
(license license:lgpl3+)))
(define-public guile-gi
- (let ((commit "26e885219ae6b31a83766564a2ecfe8c4532346f")
- (revision "1"))
- (package
- (name "guile-gi")
- (version (string-append "0.0.1-" revision "." (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/spk121/guile-gi.git")
- (commit commit)))
- (file-name (string-append name "-" version))
- (sha256
- (base32
- "1prbzhr4sqqihb34l6yfrz6sd8nghwd3q9wvbm36jnl2n3z2nxj8"))))
- (build-system gnu-build-system)
- (native-inputs `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("gettext" ,gnu-gettext)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ("texinfo" ,texinfo)))
- (propagated-inputs `(("glib" ,glib)
- ("gobject-introspection" ,gobject-introspection)
- ("gssettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("gtk+" ,gtk+)
- ("guile-lib" ,guile-lib)
- ("webkitgtk" ,webkitgtk)))
- (inputs `(("guile" ,guile-2.2)))
- (arguments
- `(#:configure-flags '("--with-gnu-filesystem-hierarchy")))
- (home-page "https://github.com/spk121/guile-gi")
- (synopsis "GObject bindings for Guile")
- (description
- "Guile-GI is a library for Guile that allows using GObject-based
+ (package
+ (name "guile-gi")
+ (version "0.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://lonelycactus.com/tarball/guile_gi-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0hs0viqzff7nzgcmyw721ima1jyymrlzrcycpgwrs6iprscxvqwn"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--with-gnu-filesystem-hierarchy")
+ ;; The atomic_int_set test does not actually fail.
+ #:make-flags '("XFAIL_TESTS=strjoinv.scm")))
+ (native-inputs
+ `(("gettext" ,gnu-gettext)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("glib" ,glib)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gssettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gtk+" ,gtk+)
+ ("guile-lib" ,guile-lib)
+ ("webkitgtk" ,webkitgtk)))
+ (inputs `(("guile" ,guile-2.2)))
+ (home-page "https://github.com/spk121/guile-gi")
+ (synopsis "GObject bindings for Guile")
+ (description
+ "Guile-GI is a library for Guile that allows using GObject-based
libraries, such as GTK+3. Its README comes with the disclaimer: This is
pre-alpha code.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public guile-srfi-159
(let ((commit "1bd98abda2ae4ef8f36761a167903e55c6bda7bb")