summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-02-04 11:16:46 +0000
committerLudovic Courtès <ludo@gnu.org>2022-02-05 00:59:30 +0100
commitf79bb5fb3cd0e0cab4c2ed0dfa1c535e2e613983 (patch)
treebfff4e5760ca8f1c30378bf359f1f0b1c1520cbd /gnu/packages/guile-xyz.scm
parent4e53625cc8b083df5717ff77756d099679002e26 (diff)
gnu: guile-fibers: Add (fibers io-wakeup).
This patch is required by gnunet-scheme. It has been submitted upstream at <https://github.com/wingo/fibers/pull/50>, but there has not been any response so far. * gnu/packages/patches/guile-fibers-wait-for-io-readiness.patch: New file. * gnu/packages/guile-xyz.scm (guile-fibers-1.1)[source]{patches}: Add it. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index f35ba43057..31405de9eb 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2021 Zelphir Kaltstahl <zelphirkaltstahl@posteo.de>
;;; Copyright © 2021 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2021, 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -612,10 +613,17 @@ Unix-style DSV format and RFC 4180 format.")
version "/fibers-" version ".tar.gz"))
(sha256
(base32
- "1lqz39shlhif5fhpyv2wili0yzb0nhf5ciiv7mdqsq0vljirhrm0"))))
+ "1lqz39shlhif5fhpyv2wili0yzb0nhf5ciiv7mdqsq0vljirhrm0"))
+ (patches
+ (search-patches "guile-fibers-wait-for-io-readiness.patch"))))
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
+ ;; This is required to make
+ ;; "guile-fibers-wait-for-io-readiness.patch" work.
+ (add-after 'unpack 'regenerate-autotools
+ (lambda _
+ (delete-file "configure")))
(add-after 'install 'mode-guile-objects
(lambda* (#:key outputs #:allow-other-keys)
;; .go files are installed to "lib/guile/X.Y/cache".
@@ -629,7 +637,9 @@ Unix-style DSV format and RFC 4180 format.")
(rename-file old new)
#t))))))
(native-inputs
- (list texinfo pkg-config))
+ (list texinfo pkg-config autoconf automake libtool
+ ;; Gettext brings 'AC_LIB_LINKFLAGS_FROM_LIBS'
+ gettext-minimal))
(inputs
(list guile-3.0))
(synopsis "Lightweight concurrency facility for Guile")