summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorCarlo Holl <carloholl@gmail.com>2020-11-25 12:16:36 -0800
committerLeo Famulari <leo@famulari.name>2020-11-25 21:02:16 -0500
commit1112b916a512c39e1fdec1f074c6da297563acfb (patch)
treefd5905f6ba500ad07fa462b7b2afc398b3c29357 /gnu/packages/haskell-xyz.scm
parentf1e73a5caf4a008b7a225520641cf2d14aa2f9be (diff)
gnu: ghc-hledger-lib: Downgrade to 0.14.1.
* gnu/packages/haskell-xyz.scm (ghc-hledger-lib): Downgrade to 0.14.1. [inputs]: Replace with what is generated by guix import. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 67395baea3..2e3fbbb5b0 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -5866,7 +5866,7 @@ accessed or modified.")
(define-public ghc-hledger-lib
(package
(name "ghc-hledger-lib")
- (version "1.19.1")
+ (version "1.14.1")
(source
(origin
(method url-fetch)
@@ -5876,14 +5876,10 @@ accessed or modified.")
".tar.gz"))
(sha256
(base32
- "0py11011r358nmnvwwkc8mlx6mpy36jm8sqlr4i8ihx3x0zjdgya"))))
+ "1w6qp01cak6spnpldm01czlm6i5a2alw47w76875l2nagrc4rfp2"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-decimal" ,ghc-decimal)
- ("ghc-glob" ,ghc-glob)
- ("ghc-aeson" ,ghc-aeson)
- ("ghc-aeson-pretty" ,ghc-aeson-pretty)
- ("ghc-ansi-terminal" ,ghc-ansi-terminal)
+ `(("ghc-ansi-terminal" ,ghc-ansi-terminal)
("ghc-base-compat-batteries" ,ghc-base-compat-batteries)
("ghc-blaze-markup" ,ghc-blaze-markup)
("ghc-call-stack" ,ghc-call-stack)
@@ -5891,11 +5887,14 @@ accessed or modified.")
("ghc-cassava-megaparsec" ,ghc-cassava-megaparsec)
("ghc-cmdargs" ,ghc-cmdargs)
("ghc-data-default" ,ghc-data-default)
+ ("ghc-decimal" ,ghc-decimal)
+ ("ghc-easytest" ,ghc-easytest)
("ghc-extra" ,ghc-extra)
- ("ghc-fgl" ,ghc-fgl)
("ghc-file-embed" ,ghc-file-embed)
+ ("ghc-glob" ,ghc-glob)
("ghc-hashtables" ,ghc-hashtables)
("ghc-megaparsec" ,ghc-megaparsec)
+ ("ghc-mtl-compat" ,ghc-mtl-compat)
("ghc-old-time" ,ghc-old-time)
("ghc-parser-combinators" ,ghc-parser-combinators)
("ghc-pretty-show" ,ghc-pretty-show)
@@ -5903,14 +5902,9 @@ accessed or modified.")
("ghc-safe" ,ghc-safe)
("ghc-split" ,ghc-split)
("ghc-tabular" ,ghc-tabular)
- ("ghc-tasty" ,ghc-tasty)
- ("ghc-tasty-hunit" ,ghc-tasty-hunit)
- ("ghc-timeit" ,ghc-timeit)
("ghc-uglymemo" ,ghc-uglymemo)
- ("ghc-unordered-containers" ,ghc-unordered-containers)
("ghc-utf8-string" ,ghc-utf8-string)))
- (native-inputs
- `(("ghc-doctest" ,ghc-doctest)))
+ (native-inputs `(("ghc-doctest" ,ghc-doctest)))
(home-page "https://hledger.org")
(synopsis "Reusable library providing the core functionality of hledger")
(description