summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-07-07 17:36:43 -0700
committerTimothy Sample <samplet@ngyro.com>2019-09-02 23:09:38 -0400
commitf169f713e467fa1d8bb878f8a377c205b40ed8cb (patch)
tree8315836c4d2ef1675cfbc3a6cf7c7a354cb8c5d1 /gnu/packages/haskell-xyz.scm
parentbc06ca458865cdf7a3b971ac34ae2f92f75c6964 (diff)
gnu: Add ghc-fmlist.
* gnu/packages/haskell-xyz.scm (ghc-fmlist): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index b67754b1b9..1130e160c2 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3555,6 +3555,30 @@ simple general-purpose data structure\".")
arithmetic.")
(license license:bsd-3)))
+(define-public ghc-fmlist
+ (package
+ (name "ghc-fmlist")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "https://hackage.haskell.org/package/fmlist/fmlist-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "02868865hqm189h5wjd916abvqwkhbrx5b0119s1dwp70ifvbi4g"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/sjoerdvisscher/fmlist")
+ (synopsis "FoldMap lists")
+ (description "FoldMap lists are lists represented by their
+@code{foldMap} function. FoldMap lists have @math{O(1)} cons, snoc and
+append, just like DLists, but other operations might have favorable
+performance characteristics as well. These wild claims are still
+completely unverified though.")
+ (license license:bsd-3)))
+
(define-public ghc-foldl
(package
(name "ghc-foldl")