summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 11:33:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:12 +0200
commit990cd5ef5006283ba5d5de4d97517afc2933221b (patch)
tree779b514e546ceed71afd457ac8a27abbf3c4f59e /gnu/packages/haskell.scm
parentcdad36c39d42b32cf805b61da88d3177a685e9df (diff)
gnu: ghc-resourcet: Update to 1.2.1.
* gnu/packages/haskell.scm (ghc-resourcet): Update to 1.2.1. [inputs]: Add ghc-unliftio-core.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b240c94f55..0e37e33c2f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1121,17 +1121,15 @@ unwanted suggestions, and to add your own custom suggestions.")
(define-public ghc-resourcet
(package
(name "ghc-resourcet")
- (version "1.1.7.5")
+ (version "1.2.1")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://hackage.haskell.org/package/resourcet/resourcet-"
- version
- ".tar.gz"))
+ (uri (string-append "https://hackage.haskell.org/package/resourcet/"
+ "resourcet-" version ".tar.gz"))
(sha256
(base32
- "0nj0gwfd05divpdn7m47gy6bpcrwn3zk81gc303k0smrbqi0xlq5"))))
+ "0rzjzh34s36ssign7akqjnwnjxf11c3511wk7ky0xxy0dqmc2rg7"))))
(build-system haskell-build-system)
(inputs
`(("ghc-transformers-base" ,ghc-transformers-base)
@@ -1139,7 +1137,8 @@ unwanted suggestions, and to add your own custom suggestions.")
("ghc-transformers-compat" ,ghc-transformers-compat)
("ghc-mtl" ,ghc-mtl)
("ghc-mmorph" ,ghc-mmorph)
- ("ghc-exceptions" ,ghc-exceptions)))
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-unliftio-core" ,ghc-unliftio-core)))
(native-inputs
`(("ghc-lifted-base" ,ghc-lifted-base)
("ghc-hspec" ,ghc-hspec)))