summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2018-08-15 12:10:05 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-08-16 17:04:12 +0200
commitde866854aa94f10af75a5e90e0bbcbedfc0a69db (patch)
tree31c406804b7191263bde3b61bbe418440bc37b6e /gnu/packages/haskell.scm
parentf8362eac6a6cd6dbd813209c72d1a915ff5f0fd0 (diff)
gnu: Add ghc-double-conversion.
* gnu/packages/haskell.scm (ghc-double-conversion): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index dada57ddb9..90734febf0 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -481,6 +481,33 @@ pure @code{Either} value. This means that you need not remember which specific
function performs the conversion you desire.")
(license license:bsd-3)))
+(define-public ghc-double-conversion
+ (package
+ (name "ghc-double-conversion")
+ (version "2.0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "double-conversion/double-conversion-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0sx2kc1gw72mjvd8vph8bbjw5whfxfv92rsdhjg1c0al75rf3ka4"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-text" ,ghc-text)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
+ (home-page "https://github.com/bos/double-conversion")
+ (synopsis "Fast conversion between double precision floating point and text")
+ (description
+ "This package provides a library that performs fast, accurate conversion
+between double precision floating point and text.")
+ (license license:bsd-3)))
+
(define-public ghc-libxml
(package
(name "ghc-libxml")