summaryrefslogtreecommitdiff
path: root/gnu/packages/high-availability.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-09-28 21:26:44 +0100
committerLudovic Courtès <ludo@gnu.org>2022-10-10 11:16:08 +0200
commit1589a825daf7d994a7236fdffdc5a2f98fe8cc38 (patch)
tree524c4d14d37b68fa18808ae0d8122f5ae4541517 /gnu/packages/high-availability.scm
parent69598d84893669b0089309b9e5d967231cae84fa (diff)
gnu: libqb: Update to 2.0.6.
* gnu/packages/high-availability.scm (libqb): Update to 2.0.6. Run `guix style' over the package. [native-inputs]: Add autoconf, automake, libtools to fix configure and build phases. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/high-availability.scm')
-rw-r--r--gnu/packages/high-availability.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/high-availability.scm b/gnu/packages/high-availability.scm
index 1a8c348020..46247c4e13 100644
--- a/gnu/packages/high-availability.scm
+++ b/gnu/packages/high-availability.scm
@@ -55,9 +55,7 @@
(define-public libqb
(package
(name "libqb")
- ;; NOTE: We are using a Release Candidate version (for 2.0) here because
- ;; of the linker issues with the previous release.
- (version "1.9.1")
+ (version "2.0.6")
(source (origin
(method url-fetch)
(uri (string-append
@@ -65,13 +63,14 @@
version "/libqb-" version ".tar.xz"))
(sha256
(base32
- "008vvw504kh40br5v2xkqavnp9vpmjvf768faqzv1d00fd53ingn"))))
+ "071k916vz9ppyb69rpk792fzjs3nf3chakn10i496scgiqh49rzi"))))
(build-system gnu-build-system)
- (native-inputs
- (list pkg-config libxml2))
+ (native-inputs (list autoconf automake libtool libxml2 pkg-config))
(home-page "https://clusterlabs.github.io/libqb/")
- (synopsis "Library providing high performance logging, tracing, ipc, and poll")
- (description "Libqb is a library with the primary purpose of providing
+ (synopsis
+ "Library providing high performance logging, tracing, ipc, and poll")
+ (description
+ "Libqb is a library with the primary purpose of providing
high-performance, reusable features for client-server architecture, such as
logging, tracing, inter-process communication (IPC), and polling. Libqb is
not intended to be an all-encompassing library, but instead provide focused