summaryrefslogtreecommitdiff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-10 13:25:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-12-10 13:25:47 +0200
commit34eaf5714efcb847c9cba03a055a17e790c1d017 (patch)
treed9c534cac0e668052e6b3c5b11602d0773aa5068 /gnu/packages/image-processing.scm
parent99f7f6457485d524c560bce428fb8c3997e2b553 (diff)
parent63e06f30ce20fa846a7e2e814976fefcd9eda7d3 (diff)
Merge remote-tracking branch 'origin/master' into rust-team
Change-Id: Ic45f7071abd6a02c2ccad411500e5103c8272ffb
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 36fee7e276..306da962cc 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -1690,7 +1690,13 @@ purposes.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1bm0wdv5p26i8nl4kx3145cz553v401sgbpgc96sddzjfmfiydcw"))))
+ (base32 "1bm0wdv5p26i8nl4kx3145cz553v401sgbpgc96sddzjfmfiydcw"))
+ (snippet
+ #~(begin (use-modules (guix build utils))
+ (substitute* "imgviz/draw.py"
+ (("collections\\.Iterable") "collections.abc.Iterable"))
+ (substitute* "imgviz/tile.py"
+ (("collections\\.Sequence") "collections.abc.Sequence"))))))
(build-system python-build-system)
(arguments
`(#:phases