summaryrefslogtreecommitdiff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-06-30 00:03:50 +0200
committerLudovic Courtès <ludo@gnu.org>2020-06-30 00:18:28 +0200
commite3e757edf936ebd8a86a72afaf4c5383e5ccf17b (patch)
tree5c58d53a9d1d7bfa5671e57775321645b52c1a4b /gnu/packages/image-viewers.scm
parent172ca314c3ad866b6dcb0896ef1a0b0b1e558ea0 (diff)
gnu: geeqie: Update to 1.5.
* gnu/packages/image-viewers.scm (geeqie): Update to 1.5. [arguments]: Add "--enable-gtk3" to #:configure-flags. Remove #:parallel-build? and #:phases.
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm101
1 files changed, 35 insertions, 66 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index 5a7d849ae1..87159dcc45 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -120,77 +120,46 @@ actions.")
"See 'COPYING' in the distribution."))))
(define-public geeqie
- ;; The latest release, 1.4, fails to build with Exiv2 0.27.1. The upstream
- ;; repo has several fixes for that, so take a snapshot.
- (let ((commit "c220ddefb1b6b11b54f7598f0d44dd0723325ed4")
- (revision "1"))
- (package
- (name "geeqie")
- (version (git-version "1.4" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/BestImageViewer/geeqie")
- (commit commit)))
- (sha256
- (base32
- "07424nzrnwbksgalgg1a6ig2snd986w79kca1cfnv1q9kc7x2h3x"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- `( ;; Enable support for a "map" pane using GPS data.
- #:configure-flags '("--enable-map")
-
- ;; Parallel builds fail with something like:
- ;; image-load.c:143:9: error: ‘gq_marshal_VOID__INT_INT_INT_INT’ undeclared
- ;; due to unexpressed makefile dependencies.
- #:parallel-build? #f
-
- #:phases
- (modify-phases %standard-phases
- (add-before 'bootstrap 'pre-bootstrap
- (lambda _
- (define (write-dummy-changelog port)
- (display "See Git history for a change log.\n" port))
- ;; Create ChangeLog{,.html} to placate the makefile, which would
- ;; otherwise require access to the Git repo.
- (call-with-output-file "ChangeLog"
- write-dummy-changelog)
- (call-with-output-file "ChangeLog.html"
- write-dummy-changelog)
-
- ;; Don't try to run 'git' for the version number.
- (substitute* "configure.ac"
- (("m4_esyscmd_s\\([^)]+\\)")
- (string-append "[" ,version "]")))
-
- ;; Remove references to non-existent files.
- (substitute* "po/POTFILES.in"
- (("^plugins/import/.*") ""))
- #t)))))
- (inputs
- `(("clutter" ,clutter)
- ("libchamplain" ,libchamplain)
- ("lcms" ,lcms)
- ("exiv2" ,exiv2)
- ("libpng" ,libpng)
- ("gtk+" ,gtk+)))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("glib" ,glib "bin") ; glib-gettextize
- ("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
- (home-page "http://www.geeqie.org/")
- (synopsis "Lightweight GTK+ based image viewer")
- (description
- "Geeqie is a lightweight GTK+ based image viewer for Unix like operating
+ (package
+ (name "geeqie")
+ (version "1.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BestImageViewer/geeqie")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0nf45sh3pwsv98sppcrqj81b6mdi31n1sbc7gn88m8mhpfp1qq6k"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `( ;; Enable support for a "map" pane using GPS data.
+ #:configure-flags '("--enable-map"
+ "--enable-gtk3")))
+ (inputs
+ `(("clutter" ,clutter)
+ ("libchamplain" ,libchamplain)
+ ("lcms" ,lcms)
+ ("exiv2" ,exiv2)
+ ("libpng" ,libpng)
+ ("gtk+" ,gtk+)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("glib" ,glib "bin") ; glib-gettextize
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "http://www.geeqie.org/")
+ (synopsis "Lightweight GTK+ based image viewer")
+ (description
+ "Geeqie is a lightweight GTK+ based image viewer for Unix like operating
systems. It features: EXIF, IPTC and XMP metadata browsing and editing
interoperability; easy integration with other software; geeqie works on files
and directories, there is no need to import images; fast preview for many raw
image formats; tools for image comparison, sorting and managing photo
collection. Geeqie was initially based on GQview.")
- (license license:gpl2+))))
+ (license license:gpl2+)))
(define-public gpicview
(package