summaryrefslogtreecommitdiff
path: root/gnu/packages/instrumentation.scm
diff options
context:
space:
mode:
authorOlivier Dion <olivier.dion@polymtl.ca>2022-08-03 19:44:28 -0400
committerMathieu Othacehe <othacehe@gnu.org>2022-08-05 14:34:51 +0200
commitbd956bc57babc427347180fd4e5f4485990811ba (patch)
treec095f281389e557336862d1573a751be02a708f3 /gnu/packages/instrumentation.scm
parent644646beab2f8bdaddf7736fa5e4dfc7e684bebd (diff)
gnu: Add perf-tools.
* gnu/packages/instrumentation.scm (perf-tools): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/instrumentation.scm')
-rw-r--r--gnu/packages/instrumentation.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index 4e23e9bed4..f52cf11505 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -18,13 +18,17 @@
(define-module (gnu packages instrumentation)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages commencement)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages documentation)
#:use-module (gnu packages elf)
#:use-module (gnu packages engineering)
+ #:use-module (gnu packages file)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages gawk)
#:use-module (gnu packages glib)
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages libunwind)
@@ -290,6 +294,60 @@ line for tracing control, a @code{lttng-ctl} library for tracing control and a
@code{lttng-relayd} for network streaming.")
(license (list license:gpl2 license:lgpl2.1))))
+(define-public perf-tools
+ (package
+ (name "perf-tools")
+ (version "1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/brendangregg/perf-tools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ab735idi0h62yvhzd7822jj3555vygixv4xjrfrdvi8d2hhz6qn"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan
+ ',(append
+ (map (cut list <> "bin/")
+ '("disk/bitesize"
+ "fs/cachestat"
+ "execsnoop"
+ "kernel/funccount"
+ "kernel/funcgraph"
+ "kernel/funcslower"
+ "kernel/functrace"
+ "iolatency"
+ "iosnoop"
+ "killsnoop"
+ "kernel/kprobe"
+ "opensnoop"
+ "misc/perf-stat-hist"
+ "tools/reset-ftrace"
+ "syscount"
+ "net/tcpretrans"
+ "system/tpoint"
+ "user/uprobe"))
+ '(("man/man8/" "share/man/man8")))))
+ (propagated-inputs
+ (list
+ bash
+ coreutils ; cat + rm
+ gawk
+ gcc-toolchain ; objdump + ldconfig
+ file
+ perf
+ perl
+ procps ; sysctl
+ which))
+ (home-page "https://github.com/brendangregg/perf-tools")
+ (synopsis "Performance analysis tools")
+ (description "Perf-tools is a collection of scripts for performance
+analysis and instrumentation based on Linux perf_events (aka perf) and
+ftrace.")
+ (license (list license:gpl2))))
+
(define-public uftrace
(package
(name "uftrace")