summaryrefslogtreecommitdiff
path: root/gnu/packages/ipfs.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-04-07 13:01:45 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-12 16:58:42 +0100
commit087d1e16a1bd1148b7842a5857eba90ce7048a8d (patch)
tree8ab62a882ccfd2797b986ea3855b3a1176f27964 /gnu/packages/ipfs.scm
parent352e649ac2094844b17e96fe15602815062acf58 (diff)
gnu: Add go-github-com-ipfs-go-cid.
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-cid): New variable. Change-Id: Ib285028ff3f93b4ec00dcc00ab557be4634acfb0 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/ipfs.scm')
-rw-r--r--gnu/packages/ipfs.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 0a1065535b..33c25d1ff4 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -39,6 +39,42 @@
#:use-module (gnu packages shells)
#:use-module (gnu packages syncthing))
+(define-public go-github-com-ipfs-go-cid
+ (package
+ (name "go-github-com-ipfs-go-cid")
+ (version "0.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-cid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gfd5dg0shj2daraai2kkf8sg24jp5cr6dsv857wp4q1ni612a23"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/ipfs/go-cid"))
+ (propagated-inputs (list go-github-com-gxed-hashland-keccakpg
+ go-github-com-minio-blake2b-simd
+ go-github-com-minio-sha256-simd
+ go-github-com-mr-tron-base58
+ go-github-com-multiformats-go-base32
+ go-github-com-multiformats-go-base36
+ go-github-com-multiformats-go-multihash-0.2.3
+ go-github-com-multiformats-go-multibase
+ go-github-com-multiformats-go-varint
+ go-github-com-spaolacci-murmur3
+ go-golang-org-x-crypto))
+ (home-page "https://github.com/ipfs/go-cid")
+ (synopsis "Content ID v1 implemented in Go")
+ (description
+ "Implementation in Go of the @url{https://github.com/ipld/cid, CID spec}. It is
+used in @code{go-ipfs} and related packages to refer to a typed hunk of data.")
+ (license license:expat)))
+
(define-public go-github-com-ipfs-go-ipfs-cmdkit-files
(let ((commit
"386fcf8f18a185ec121676665fe2d9574496048d")