summaryrefslogtreecommitdiff
path: root/gnu/packages/ipfs.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-06-12 08:37:45 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-17 22:55:56 +0100
commit6515cff981f564fc68816ffca260cd70f6250f70 (patch)
tree15ec03f05b0224e7f61093d863b73379127736da /gnu/packages/ipfs.scm
parente535a2c30edb26b54aa683e45e55eb5e3885a2da (diff)
gnu: kubo: Unbundle more inputs.
* gnu/packages/ipfs.scm (kubo): Unbundle more inputs. [inputs]: Add go-github-com-ipfs-go-block-format, go-github-com-ipfs-go-ipld-format, go-github-com-ipfs-go-datastore Change-Id: Ia2f7a936d2af4f75c65cc0c0dc230982cc646ef8 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/ipfs.scm')
-rw-r--r--gnu/packages/ipfs.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 241441fd69..7fb50452b6 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -544,9 +544,14 @@ written in Go.")
"vendor/github.com/google/uuid"
"vendor/github.com/gorilla"
"vendor/github.com/hashicorp"
+ "vendor/github.com/ipfs/go-block-format"
"vendor/github.com/ipfs/go-cid"
"vendor/github.com/ipfs/go-cidutil"
+ "vendor/github.com/ipfs/go-datastore"
+ "vendor/github.com/ipfs/go-detect-race"
+ "vendor/github.com/ipfs/go-ipfs-delay"
"vendor/github.com/ipfs/go-ipfs-util"
+ "vendor/github.com/ipfs/go-ipld-format"
"vendor/github.com/ipfs/go-log"
"vendor/github.com/jackpal"
"vendor/github.com/jbenet"
@@ -617,11 +622,10 @@ written in Go.")
go-github-com-google-uuid
go-github-com-hashicorp-go-multierror
;;go-github-com-ipfs-boxo
- ;;go-github-com-ipfs-go-block-format
+ go-github-com-ipfs-go-block-format
go-github-com-ipfs-go-cid
go-github-com-ipfs-go-cidutil
- ;;go-github-com-ipfs-go-datastore
- ;;go-github-com-ipfs-go-detect-race
+ go-github-com-ipfs-go-datastore
;;go-github-com-ipfs-go-ds-badger
;;go-github-com-ipfs-go-ds-flatfs
;;go-github-com-ipfs-go-ds-leveldb
@@ -629,7 +633,7 @@ written in Go.")
;;go-github-com-ipfs-go-fs-lock
;;go-github-com-ipfs-go-ipfs-cmds
;;go-github-com-ipfs-go-ipld-cbor
- ;;go-github-com-ipfs-go-ipld-format
+ go-github-com-ipfs-go-ipld-format
;;go-github-com-ipfs-go-ipld-git
;;go-github-com-ipfs-go-ipld-legacy
go-github-com-ipfs-go-log