summaryrefslogtreecommitdiff
path: root/gnu/packages/ipfs.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-06-12 08:37:44 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-17 22:55:55 +0100
commitdbd078a5c972f60a2d05709a2fe2f5fc417e396d (patch)
tree01218ff1e012b8a39fdedf7fdd51ed7c98bfb421 /gnu/packages/ipfs.scm
parent4797bbb12c7c7c93ce6fa6267b46816b6d239f86 (diff)
gnu: Add go-github-com-ipfs-go-ipld-format.
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-ipld-format): New variable. Change-Id: I65aa1c71cf092c4923c9c4484498d6af684b215a Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/ipfs.scm')
-rw-r--r--gnu/packages/ipfs.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 6df340e402..505003229c 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -207,6 +207,35 @@ that are shared between @command{go-ipfs/commands} and its rewrite
"Common utilities used by @code{go-ipfs} and other related Go packages.")
(license license:expat)))
+(define-public go-github-com-ipfs-go-ipld-format
+ (package
+ (name "go-github-com-ipfs-go-ipld-format")
+ (version "0.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipld-format")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zl172ncmx9h5z2p3d0j1377xm9glw4zfyamks31p0pvvx2kyn7c"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/ipfs/go-ipld-format"))
+ (propagated-inputs
+ (list go-github-com-multiformats-go-multihash
+ go-github-com-ipfs-go-block-format
+ go-github-com-ipfs-go-cid))
+ (home-page "https://github.com/ipfs/go-ipld-format")
+ (synopsis "IPLD Node and Resolver interfaces in Go")
+ (description
+ "@code{go-ipld-format} is a set of interfaces that a type needs to implement in
+order to be a part of the @acronym{IPLD, InterPlanetary Linked Data} merkle-forest.")
+ (license license:expat)))
+
(define-public go-github-com-ipfs-go-ipfs-api
(let ((commit
"dafc2a13a4389ac1a6c2786e34ab70a4f26d3a3f")