summaryrefslogtreecommitdiff
path: root/gnu/packages/jami.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-25 16:41:55 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-31 21:55:49 -0400
commit46f5623cc19805c8d65011b2650be85156769c86 (patch)
tree91d441a7bc9144c65c8654a0fa32498cd76df8f5 /gnu/packages/jami.scm
parent3d812fea06432db6ae31e5cc1ca454097cc09d60 (diff)
gnu: Remove jami-libclient.
* gnu/packages/jami.scm (jami-libclient): Delete variable. (libringclient): Likewise. (jami-gnome)[inputs]: Remove jami-libclient. (jami)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/jami.scm')
-rw-r--r--gnu/packages/jami.scm48
1 files changed, 1 insertions, 47 deletions
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 7269b06a33..de80c8a64f 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -474,50 +474,6 @@ protocols, as well as decentralized calling using P2P-DHT.")
(define-public libring
(deprecated-package "libring" libjami))
-;;; Note: this package will eventually be absorbed into jami itself (the Qt
-;;; client).
-(define-public jami-libclient
- (package
- (name "jami-libclient")
- (version %jami-version)
- (source %jami-sources)
- (build-system cmake-build-system)
- (outputs '("out" "debug"))
- (arguments
- (list
- #:tests? #f ;no test suite
- #:configure-flags
- #~(list (string-append "-DRING_XML_INTERFACES_DIR="
- #$(this-package-input "libjami")
- "/share/dbus-1/interfaces")
- (string-append "-DRING_BUILD_DIR="
- #$(this-package-input "libjami")
- "/include")
- ;; Call to the libraries directly instead of going through DBus
- ;; to avoid issues (see: https://issues.guix.gnu.org/48538).
- "-DENABLE_LIBWRAP=true")
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'change-directory/maybe
- (lambda _
- ;; Allow building from the tarball or a git checkout.
- (false-if-exception (chdir "lrc")))))))
- (native-inputs (list qttools vulkan-headers))
- (inputs (list ffmpeg-jami libjami libxkbcommon network-manager))
- (propagated-inputs (list qtbase)) ;qt included in several installed headers
- (synopsis "Jami client library")
- (description "This package provides a library common to all Jami clients.
-Jami is a secure and distributed voice, video and chat communication platform
-that requires no centralized server and leaves the power of privacy in the
-hands of the user. It supports the SIP and IAX protocols, as well as
-decentralized calling using P2P-DHT.")
- (home-page "https://jami.net")
- (license license:gpl3+)))
-
-;;; Remove when 2023 comes.
-(define-public libringclient
- (deprecated-package "libringclient" jami-libclient))
-
(define-public jami-gnome
(package
(name "jami-gnome")
@@ -557,7 +513,6 @@ decentralized calling using P2P-DHT.")
(list clutter
clutter-gtk
gtk+
- jami-libclient
libcanberra
libappindicator
libnotify
@@ -612,8 +567,7 @@ decentralized calling using P2P-DHT.")
(native-inputs
(list pkg-config python qttools-5 doxygen graphviz))
(inputs
- (list jami-libclient
- libnotify
+ (list libnotify
network-manager
qrencode
qtsvg-5