summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 10:35:31 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:49 +0300
commitfda20c75216c8459165107460b8ed6cc7cb5f292 (patch)
treef4a9eacb742261e63cb15d8e18437f2fc50d67d5 /gnu/packages/julia-jll.scm
parent0083404175a8da57ab165d4517ad743990b27edc (diff)
gnu: julia-zlib-jll: Move to (gnu packages julia-jll).
* gnu/packages/julia-xyz.scm (julia-zlib-jll): Move to ... * gnu/packages/julia-jll.scm: ... here.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index a403829ff2..9d6d692f8a 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -25,6 +25,7 @@
#:use-module (guix utils)
#:use-module (guix build-system julia)
#:use-module (gnu packages)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
#:use-module (gnu packages image)
#:use-module (gnu packages julia)
@@ -279,3 +280,41 @@ autogenerated source package constructed using @code{BinaryBuilder.jl}. The
originating @code{build_tarballs.jl} script can be found on the community
build tree Yggdrasil.")
(license license:expat))))
+
+(define-public julia-zlib-jll
+ (package
+ (name "julia-zlib-jll")
+ (version "1.2.12+1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Zlib_jll.jl")
+ (commit (string-append "Zlib-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05ih0haqapkzr40swvq63cafnqlc4yp6yfa1wvdyq8v3n4kxhfqa"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"Zlib\", \""
+ (assoc-ref inputs "zlib") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("zlib" ,zlib)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Zlib_jll.jl")
+ (synopsis "Zlib library wrappers")
+ (description "This package provides a wrapper for Zlib.")
+ (license license:expat)))