summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-14 17:17:13 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-21 19:22:55 +0200
commitbedb7311e10dc54c97c215266bbe12bb70b70ece (patch)
treedb2471f7bcc095e4700329b2d156704b407dac13 /gnu/packages/julia-xyz.scm
parent53436955c42430690457e89399984709894616c0 (diff)
gnu: julia-matrixfactorizations: Update to 0.9.3.
* gnu/packages/julia-xyz.scm (julia-matrixfactorizations): Update to 0.9.3. [arguments]: Re-enable one of the skipped tests.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 6a610a3268..f85be84ebf 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3634,7 +3634,7 @@ comes from the fact that @code{M == map(f, A)}.")
(define-public julia-matrixfactorizations
(package
(name "julia-matrixfactorizations")
- (version "0.8.4")
+ (version "0.9.3")
(source
(origin
(method git-fetch)
@@ -3643,7 +3643,7 @@ comes from the fact that @code{M == map(f, A)}.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "15zvcv2l4iqmjpnqjyx2kry7a85p652nbjy9pj3wq0piksqcz4jb"))))
+ (base32 "0sqmig01irmvh617h2rsw44hl39qwv2913nlqjsdz9si5vli2hsl"))))
(build-system julia-build-system)
(arguments
(list
@@ -3651,10 +3651,8 @@ comes from the fact that @code{M == map(f, A)}.")
#~(modify-phases %standard-phases
(add-after 'link-depot 'skip-failing-test
(lambda _
- ;; Tests with math functions are hard.
(substitute* "test/test_ul.jl"
- (("@test @inferred\\(logdet") "@test @test_nowarn(logdet")
- ;; Also skip the REPL test.
+ ;; Don't warn on the REPL test.
(("test String") "test_nowarn String")))))))
(propagated-inputs
(list julia-arraylayouts))