summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-28 15:53:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-28 16:05:33 +0300
commitc20c9e1685c07bc276470029842e817a669b35ef (patch)
treeab66142888a21055b1631cf7e3ac4564244fe6ab /gnu/packages/julia-xyz.scm
parentfcc900bd52017f38a99ea1c3c54ea52510488695 (diff)
gnu: julia-distances: Update flakey tests.
* gnu/packages/julia-xyz.scm (julia-distances)[arguments]: Adjust the custom 'skip-flakey-tests phase.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 71f701e7ca..0a45204abf 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -925,10 +925,13 @@ dictionaries in Julia, for improved productivity and performance.")
(modify-phases %standard-phases
(add-after 'unpack 'skip-flakey-tests
(lambda _
+ ;; Some combination of these tests fail nondeterministically
+ ;; each of the times this package is built.
(substitute* "test/test_dists.jl"
(("test dyz ≥") "test_nowarn dyz ≥")
(("test dist\\(y, x") "test_nowarn dist(y, x")
- (("test dist\\(z, x") "test_nowarn dist(z, x")))))))
+ (("test dist\\(z, x") "test_nowarn dist(z, x")
+ (("test dist\\(z, y") "test_nowarn dist(z, y")))))))
(propagated-inputs
`(("julia-statsapi" ,julia-statsapi)))
(native-inputs