summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-07-06 20:06:40 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-07-11 13:03:31 +0300
commite4caadb0966cc4d1fca1470464c40de769ae3584 (patch)
tree1d5becc4c28dfbada921bc917996a934ce991bfb /gnu/packages/julia-xyz.scm
parent4a519a109273be20e424ca3136a5c2b78bff042a (diff)
gnu: Add julia-inlinestrings.
* gnu/packages/julia-xyz.scm (julia-inlinestrings): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index c6f3ad5d61..49816507bd 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2847,6 +2847,32 @@ negative infinity in Julia.")
interfaces with @file{.ini} files.")
(license license:expat)))
+(define-public julia-inlinestrings
+ (package
+ (name "julia-inlinestrings")
+ (version "1.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaStrings/InlineStrings.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dcdpxlphjliqlnkcri7mhg9bqqzpsdj80h9gkw8xhzr3ls473zr"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ (list julia-parsers))
+ (home-page "https://github.com/JuliaStrings/InlineStrings.jl")
+ (synopsis "Fixed-width string types")
+ (description "This package provides a set of custom string types of
+various fixed sizes. Each inline string is a custom primitive type and can
+benefit from being stack friendly by avoiding allocations/heap tracking in the
+GC. When used in an array, the elements are able to be stored inline since
+each one has a fixed size. Currently support inline strings from 1 byte up to
+255 bytes.")
+ (license license:expat)))
+
(define-public julia-interpolations
(package
(name "julia-interpolations")