summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-28 15:31:51 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-28 16:05:33 +0300
commitf7eaa69dc2effb75ff17a2f91d6a31f3b335ee1c (patch)
treec58e0f0fe2735756f6646296ba644e2f66414996 /gnu/packages/julia-xyz.scm
parent6886c4960dd4d8913113ae0330cd8b2d27947a57 (diff)
gnu: Add julia-preferences.
* gnu/packages/julia-xyz.scm (julia-preferences): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index f7a9fdb1f5..fe9d63c4a2 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2902,6 +2902,31 @@ Hessian and g the gradient) may not be a descent direction if H is not positive
definite.")
(license license:expat)))
+(define-public julia-preferences
+ (package
+ (name "julia-preferences")
+ (version "1.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaPackaging/Preferences.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cail43iqzbi6m9v6981rhz47zf2lcvhs5ds5gdqvc9nx5frghxq"))))
+ (build-system julia-build-system)
+ (arguments
+ `(#:tests? #f)) ; Tests try to mkdir /.julia
+ (home-page "https://github.com/JuliaPackaging/Preferences.jl")
+ (synopsis "Store configuration switches to TOML files")
+ (description "The @code{Preferences} package provides an integrated way for
+packages to store configuration switches to persistent TOML files, and use those
+pieces of information at both run time and compile time in Julia. This enables
+the user to modify the behavior of a package, and have that choice reflected in
+everything from run time algorithm choice to code generation at compile time.")
+ (license license:expat)))
+
(define-public julia-prettytables
(package
(name "julia-prettytables")