summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-16 01:12:35 +0200
committerMarius Bakke <marius@gnu.org>2022-10-16 01:12:35 +0200
commit617c083e7b50a189cf8cc1886a2365099df50a10 (patch)
treed875d5ed3990cd52956438c6e2758cef63a34e21 /gnu/packages/kde-frameworks.scm
parentc567a82a6975e70c8207a4aeed55a72b5121213c (diff)
gnu: kwayland: Use qt-build-system and enable all tests.
* gnu/packages/kde-frameworks.scm (kwayland)[build-system]: Change to QT-BUILD-SYSTEM to avoid overriding the check phase, and to get verbose output on failure. [arguments]: Add #:parallel-build?. Remove skip-specific-tests phase. Don't override check phase, but add new to set XDG_RUNTIME_DIR.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm23
1 files changed, 9 insertions, 14 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 20b30066a2..2edfc6bd64 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1047,25 +1047,20 @@ protocols used in KDE Plasma.")
(sha256
(base32
"0dcnsiippwxvwvf1gvp75lx97c4nydzn3x1l8lfy86w9lfslw7zb"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
(list extra-cmake-modules pkg-config))
(inputs
(list qtbase-5 plasma-wayland-protocols qtwayland-5 wayland wayland-protocols))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-specific-tests
- (lambda _
- ;; PlasmaWindowModelTest::testChangeWindowAfterModelDestroy(icon)
- (substitute* "autotests/client/test_plasma_window_model.cpp"
- ((".*changedSpy\\.wait.*") ""))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (setenv "XDG_RUNTIME_DIR" (getcwd))
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (when tests? ;; One test fails.
- (invoke "ctest" "-E" "kwayland-testWaylandRegistry")))))))
+ (list
+ ;; Tests spawn Wayland sessions that cannot run in parallel.
+ #:parallel-tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-XDG_RUNTIME_DIR
+ (lambda _
+ (setenv "XDG_RUNTIME_DIR" (getcwd)))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Qt-style API to interact with the wayland client and server")
(description "As the names suggest they implement a Client respectively a