summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2023-08-16 13:04:26 +0200
committer宋文武 <iyzsong@member.fsf.org>2023-08-17 18:26:55 +0800
commit731413a680a33ed1ad909e41e5b388561a63f365 (patch)
treed1c6251fdb66b211471f6aeae179b6b87e4b1c2b /gnu/packages/kde-frameworks.scm
parent461602d07c8da0e29bae392270f4ef3fd4f7fffb (diff)
gnu: extra-cmake-modules: Fix libexec path.
* gnu/packages/kde-frameworks.scm (extra-cmake-modules)[#:phases]: Set LIBEXECDIR to 'libexec' instead of 'lib/libexec'. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 9778d9a1c6..ec7b5c041b 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -126,11 +126,13 @@
(not (null? (package-native-inputs this-package))))
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'fix-lib-path
+ (add-after 'unpack 'fix-lib-and-libexec-path
(lambda _
- ;; Always install into /lib and not into /lib64.
(substitute* "kde-modules/KDEInstallDirsCommon.cmake"
- (("\"lib64\"") "\"lib\""))
+ ;; Always install into /lib and not into /lib64.
+ (("\"lib64\"") "\"lib\"")
+ ;; Install into /libexec and not into /lib/libexec.
+ (("LIBDIR \"libexec\"") "EXECROOTDIR \"libexec\""))
;; Determine the install path by the major version of Qt.
;; TODO: Base the following on values taken from Qt