summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2021-10-14 18:11:57 +1100
committerMarius Bakke <marius@gnu.org>2022-09-01 16:08:15 +0200
commit7fc78b2d34e8914fa98114dd11ae85a47e7e6e89 (patch)
treef426c228b196844ffffea5565832090dc20c579d /gnu/packages/kde-plasma.scm
parent65ebef38b8f2ba6b12ec02e7c4e5f57efc1caa80 (diff)
gnu: Add layer-shell-qt.
* gnu/packages/kde-plasma.scm (layer-shell-qt): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index da6912affe..39716187fd 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,6 +38,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg)
#:use-module (gnu packages web))
@@ -157,6 +159,32 @@ directly, you need to tell @code{ssh-add} about it. @code{ssh-add} will then
call it if it is not associated to a terminal.")
(license license:gpl2+)))
+(define-public layer-shell-qt
+ (package
+ (name "layer-shell-qt")
+ (version "5.24.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version
+ "/layer-shell-qt-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1aq089pws39w9ncsiqzgg3qvfg5hc5a74pzra0smdpy5ipfsb6a4"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules pkg-config))
+ (inputs
+ (list libxkbcommon
+ qtbase-5
+ qtdeclarative-5
+ qtwayland
+ wayland
+ wayland-protocols))
+ (home-page "https://invent.kde.org/plasma/layer-shell-qt")
+ (synopsis "Qt component for the Wayland ql-layer-shell protocol")
+ (description "Qt component for the Wayland ql-layer-shell protocol.")
+ (license license:gpl2+)))
+
(define-public kscreenlocker
(package
(name "kscreenlocker")