summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-08-26 05:54:06 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:11 +0100
commitf17f1e1f71fbc8b645f5ffe70600e4a51adb52b0 (patch)
tree427a79b9f76d02630132e84c0590f8366d9923ab /gnu/packages/kde-plasma.scm
parentc3358f9bc5c8b1607630915a129fc1ca3deefdb3 (diff)
gnu: Add drkonqi.
* gnu/packages/kde-plasma.scm (drkonqi): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 073b4f972e..20d2b27755 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -126,6 +126,47 @@ Breeze is the default theme for the KDE Plasma desktop.")
(license (list license:bsd-3 ;cmake/FindSass.cmake
license:lgpl2.1+)))) ;<all other files>
+(define-public drkonqi
+ (package
+ (name "drkonqi")
+ (version "5.25.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/"
+ version "/" name "-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0vw4bfld2jdiwm4g3008x8s1lq1ydf87ckb0fvyzsp11hq9nnnk7"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "ctest" "-E" "connectiontest")))))))
+ (native-inputs (list extra-cmake-modules))
+ (inputs (list ki18n
+ kcoreaddons
+ kconfig
+ kservice
+ kdeclarative
+ kjobwidgets
+ kio
+ kcrash
+ kcompletion
+ kwidgetsaddons
+ kwallet
+ knotifications
+ kidletime
+ kwindowsystem
+ ksyntaxhighlighting
+ qtdeclarative-5))
+ (synopsis "Crash handler for KDE software")
+ (description "This package provides an automatic handler for crashed apps.")
+ (home-page "https://invent.kde.org/plasma/drkonqi")
+ (license license:gpl2+)))
+
(define-public kactivitymanagerd
(package
(name "kactivitymanagerd")