summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-03 01:26:13 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-03 02:21:21 +0200
commit1f0e1c49aa83d5d180f4f5ee945085eeb2d62191 (patch)
treeca85a04200df12bbcad05120e9fe79de76dc1203 /gnu/packages/linux.scm
parentc45431a2838644bae90613690b023019b8bce456 (diff)
gnu: i2c-tools: Actually cross-compile.
* gnu/packages/linux.scm (i2c-tools)[arguments]: Use CC-FOR-TARGET.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4acd50879e..1466165aa3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3595,10 +3595,10 @@ create a firmware image suitable for the Linux kernel, and more.")
"000pvg995qy1b15ks59gd0klri55hb33kqpg5czy84hw1pbdgm0l"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no 'check' target
+ `(#:tests? #f ; no 'check' target
#:make-flags (list (string-append "prefix=" %output)
- "CC=gcc")
- ;; no configure script
+ ,(string-append "CC=" (cc-for-target)))
+ ;; No configure script.
#:phases (modify-phases %standard-phases (delete 'configure))))
(inputs
`(("perl" ,perl)))