summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-26 16:28:26 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-26 19:58:30 +0200
commit616fa14b8cf106154865974d17b1b34b25220ec8 (patch)
treef0804d85a83e4aba8254289660e9f7415797ebd8 /gnu/packages/linux.scm
parent17881f944e84b560dcc1537257e454f8de306001 (diff)
gnu: pipewire: Update to 0.3.10.
* gnu/packages/linux.scm (pipewire): Update to 0.3.10. [arguments]: Set the ‘udevrulesdir’ configure flag.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4834aa4dae..0b603cfa0d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7208,7 +7208,7 @@ of Linux application development.")
(package
(inherit pipewire)
(name "pipewire")
- (version "0.3.7")
+ (version "0.3.10")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -7217,12 +7217,15 @@ of Linux application development.")
(file-name (git-file-name name version))
(sha256
(base32
- "04l66p0wj553gp2zf3vwwh6jbr1vkf6wrq4za9zlm9dn144am4j2"))))
+ "1y293sfhhmzbgnlvs46bpiyimlii5nk71f8115qxs8sviwlsdr3w"))))
(arguments
- '(#:configure-flags '("-Dsystemd=false")
+ '(#:configure-flags
+ (list (string-append "-Dudevrulesdir=" (assoc-ref %outputs "out")
+ "/lib/udev/rules.d")
+ "-Dsystemd=false")
#:phases
(modify-phases %standard-phases
- ;; Skip shrink-runpath, otherwise validate-runpath fails
+ ;; Skip shrink-runpath, otherwise validate-runpath fails.
(delete 'shrink-runpath))))
(inputs
(append (package-inputs pipewire)