summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-06-17 14:06:57 +0200
committerLeo Famulari <leo@famulari.name>2024-06-17 12:02:28 -0400
commit6fad0fd1c32db2cb25447b694f08d5c7836536ad (patch)
tree3705ac77d96559ad2539cb77dcff72967b5ee3b7 /gnu/packages/linux.scm
parentf9ed5788fda9288301550c641820d422e9ad1602 (diff)
gnu: Remove linux-libre 6.8.
* gnu/packages/linux.scm (linux-libre-6.8-version, linux-libre-6.8-gnu-revision, deblob-scripts-6.8, linux-libre-6.8-pristine-source, linux-libre-6.8-source, linux-libre-headers-6.8, linux-libre-6.8): Remove variables. * gnu/packages/aux-files/linux-libre/6.8-arm.conf, gnu/packages/aux-files/linux-libre/6.8-arm64.conf, gnu/packages/aux-files/linux-libre/6.8-riscv.conf gnu/packages/aux-files/linux-libre/6.8-i686.conf, gnu/packages/aux-files/linux-libre/6.8-x86_64.conf: Delete files. * Makefile.am (AUX_FILES): Remove aforementioned .conf files. Signed-off-by: Leo Famulari <leo@famulari.name> Change-Id: Ib94c61f629721f94a307e51b449e5ccd117a2f9a
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm38
1 files changed, 2 insertions, 36 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 01dbe643ff..9e5482ba8d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -508,7 +508,8 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(sha256 hash)))
-;; The current "mainline" kernel.
+;; The current "stable" kernels. That is, the most recently released major
+;; versions that are still supported upstream.
(define-public linux-libre-6.9-version "6.9.4")
(define-public linux-libre-6.9-gnu-revision "gnu")
@@ -525,23 +526,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(%upstream-linux-source version hash)
deblob-scripts-6.9)))
-;; The current "stable" kernels. That is, the most recently released major
-;; versions that are still supported upstream.
-
-(define-public linux-libre-6.8-version "6.8.12")
-(define-public linux-libre-6.8-gnu-revision "gnu")
-(define deblob-scripts-6.8
- (linux-libre-deblob-scripts
- linux-libre-6.8-version
- linux-libre-6.8-gnu-revision
- (base32 "17gvccv60mcpi8l9d83p4jh56vhwsv62blahz774kzyb40j8jsd4")
- (base32 "049qgwx6njh139vzdhgyzpfbc58vqs66nbsyblq6vszqrz27kmki")))
-(define-public linux-libre-6.8-pristine-source
- (let ((version linux-libre-6.8-version)
- (hash (base32 "0fb0m0fv4521g63gq04d7lm6hy8169s1rykiav5bkd99s9b1kcqr")))
- (make-linux-libre-source version
- (%upstream-linux-source version hash)
- deblob-scripts-6.8)))
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
@@ -670,11 +654,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(list %boot-logo-patch
%linux-libre-arm-export-__sync_icache_dcache-patch)))
-(define-public linux-libre-6.8-source
- (source-with-patches linux-libre-6.8-pristine-source
- (list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch)))
-
(define-public linux-libre-6.6-source
(source-with-patches linux-libre-6.6-pristine-source
(list %boot-logo-patch
@@ -795,11 +774,6 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
linux-libre-6.9-gnu-revision
linux-libre-6.9-source))
-(define-public linux-libre-headers-6.8
- (make-linux-libre-headers* linux-libre-6.8-version
- linux-libre-6.8-gnu-revision
- linux-libre-6.8-source))
-
(define-public linux-libre-headers-6.6
(make-linux-libre-headers* linux-libre-6.6-version
linux-libre-6.6-gnu-revision
@@ -1165,14 +1139,6 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
"aarch64-linux" "powerpc64le-linux" "riscv64-linux")
#:configuration-file kernel-config))
-(define-public linux-libre-6.8
- (make-linux-libre* linux-libre-6.8-version
- linux-libre-6.8-gnu-revision
- linux-libre-6.8-source
- '("x86_64-linux" "i686-linux" "armhf-linux"
- "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
- #:configuration-file kernel-config))
-
(define-public linux-libre-version linux-libre-6.9-version)
(define-public linux-libre-gnu-revision linux-libre-6.9-gnu-revision)
(define-public linux-libre-pristine-source linux-libre-6.9-pristine-source)