summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-01-08 14:50:36 +0100
committerLeo Famulari <leo@famulari.name>2024-01-17 15:23:35 -0500
commit95a3aaf7ad37bb0717f2c9e3faf6f636b586d133 (patch)
tree135dc16f8e81d73e51063dda3387b1f1040a3198 /gnu/packages/linux.scm
parent8ca490e6600c55b2dab5db12cf1aefa2b1b27f9a (diff)
gnu: Add linux-libre 6.7.
* gnu/packages/linux.scm (linux-libre-6.7-version, linux-libre-6.7-gnu-revision, deblob-scripts-6.7, linux-libre-6.7-pristine-source, linux-libre-6.7-source, linux-libre-headers-6.7, linux-libre-6.7): New variables. * gnu/packages/aux-files/linux-libre/6.7-arm.conf, gnu/packages/aux-files/linux-libre/6.7-arm64.conf, gnu/packages/aux-files/linux-libre/6.7-i686.conf, gnu/packages/aux-files/linux-libre/6.7-x86.conf: New files. * Makefile.am (AUX_FILES): Add them. * Makefile.am: Update my copyright header. Change-Id: I88b633933875f64bd2859774419e077d8f36d75b Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3cd63df6ee..3827cd3a97 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -491,6 +491,23 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
"linux-" version ".tar.xz"))
(sha256 hash)))
+;; The current "mainline" kernel.
+
+(define-public linux-libre-6.7-version "6.7")
+(define-public linux-libre-6.7-gnu-revision "gnu")
+(define deblob-scripts-6.7
+ (linux-libre-deblob-scripts
+ linux-libre-6.7-version
+ linux-libre-6.7-gnu-revision
+ (base32 "0hwashmml56r74kgjb637b3ln2d7f9vgfl18sxvczyl84xlbcncj")
+ (base32 "0pivh1hjc5ylgcyjx0z7x1dqax614pai502idzil98j35pwa24za")))
+(define-public linux-libre-6.7-pristine-source
+ (let ((version linux-libre-6.7-version)
+ (hash (base32 "0s8hbcsg7fdvspqam8kzcxygjsznr4zfi60nqgc81l3n4m518cgg")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-6.7)))
+
;; The current "stable" kernels. That is, the most recently released major
;; versions that are still supported upstream.
@@ -630,6 +647,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-6.7-source
+ (source-with-patches linux-libre-6.7-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
(define-public linux-libre-6.6-source
(source-with-patches linux-libre-6.6-pristine-source
(list %boot-logo-patch
@@ -749,6 +771,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-6.7
+ (make-linux-libre-headers* linux-libre-6.7-version
+ linux-libre-6.7-gnu-revision
+ linux-libre-6.7-source))
+
(define-public linux-libre-headers-6.6
(make-linux-libre-headers* linux-libre-6.6-version
linux-libre-6.6-gnu-revision
@@ -1107,6 +1134,14 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
(define-public linux-libre-source linux-libre-6.6-source)
(define-public linux-libre linux-libre-6.6)
+(define-public linux-libre-6.7
+ (make-linux-libre* linux-libre-6.7-version
+ linux-libre-6.7-gnu-revision
+ linux-libre-6.7-source
+ '("x86_64-linux" "i686-linux" "armhf-linux"
+ "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
(define-public linux-libre-6.1
(make-linux-libre* linux-libre-6.1-version
linux-libre-6.1-gnu-revision