summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-01-29 02:21:30 -0500
committerMark H Weaver <mhw@netris.org>2018-01-30 03:51:21 -0500
commitadbe6dea33b66624b8f6d0e60fa091991c8c5e25 (patch)
tree7bd7fd9bb0e533e411718d77765854ad912d9ff6 /gnu/packages/linux.scm
parentf2a6eca361a3abb15fdfa75548e960e76074117e (diff)
gnu: linux-libre: Update to 4.15, while retaining 4.14 LTS.
* gnu/packages/linux.scm (%linux-libre-version): Update to 4.15. (%linux-libre-hash): Update hash. (%linux-libre-arm-generic-4.14, %linux-libre-arm-omap2plus-4.14) (%linux-libre-4.1-version, %linux-libre-4.1-hash): New variables. * gnu/packages/aux-files/linux-libre/4.15-arm.conf, gnu/packages/aux-files/linux-libre/4.15-i686.conf, gnu/packages/aux-files/linux-libre/4.15-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm29
1 files changed, 26 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3de186c448..064a26bc72 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -378,19 +378,28 @@ It has been modified to remove all non-free binary blobs.")
(define %intel-compatible-systems '("x86_64-linux" "i686-linux"))
(define %linux-compatible-systems '("x86_64-linux" "i686-linux" "armhf-linux"))
-(define %linux-libre-version "4.14.15")
-(define %linux-libre-hash "0s94d51bym3zipxf40xjzq943b7b2x4ba1gp3j7l5npj5nr2xiy8")
-
;; linux-libre configuration for armhf-linux is derived from Debian armmp. It
;; supports qemu "virt" machine and possibly a large number of ARM boards.
;; See : https://wiki.debian.org/DebianKernel/ARMMP.
+(define %linux-libre-version "4.15")
+(define %linux-libre-hash "11h1954mkyy2wc0c9jd9dxysqq9wrjr6jmsxdysdd73g50a6amg6")
+
(define-public linux-libre
(make-linux-libre %linux-libre-version
%linux-libre-hash
%linux-compatible-systems
#:configuration-file kernel-config))
+(define %linux-libre-4.14-version "4.14.15")
+(define %linux-libre-4.14-hash "0s94d51bym3zipxf40xjzq943b7b2x4ba1gp3j7l5npj5nr2xiy8")
+
+(define-public linux-libre-4.14
+ (make-linux-libre %linux-libre-4.14-version
+ %linux-libre-4.14-hash
+ %linux-compatible-systems
+ #:configuration-file kernel-config))
+
(define-public linux-libre-4.9
(make-linux-libre "4.9.78"
"12j7nxz92krq2ax7rii4pr6y1pr37n7ml692kqifpzpbzqm5yb9k"
@@ -416,6 +425,13 @@ It has been modified to remove all non-free binary blobs.")
#:defconfig "multi_v7_defconfig"
#:extra-version "arm-generic"))
+(define-public linux-libre-arm-generic-4.14
+ (make-linux-libre %linux-libre-4.14-version
+ %linux-libre-4.14-hash
+ '("armhf-linux")
+ #:defconfig "multi_v7_defconfig"
+ #:extra-version "arm-generic"))
+
(define-public linux-libre-arm-omap2plus
(make-linux-libre %linux-libre-version
%linux-libre-hash
@@ -423,6 +439,13 @@ It has been modified to remove all non-free binary blobs.")
#:defconfig "omap2plus_defconfig"
#:extra-version "arm-omap2plus"))
+(define-public linux-libre-arm-omap2plus-4.14
+ (make-linux-libre %linux-libre-4.14-version
+ %linux-libre-4.14-hash
+ '("armhf-linux")
+ #:defconfig "omap2plus_defconfig"
+ #:extra-version "arm-omap2plus"))
+
;;;
;;; Pluggable authentication modules (PAM).