summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2021-09-04 15:58:21 -0400
committerLudovic Courtès <ludo@gnu.org>2021-11-18 14:11:43 +0100
commitb0eaa4f2d73cd7746a41d1f970b95243f2098458 (patch)
tree1de0979eb5e1e3f5a4b7a0fd837d4ce23427251f /gnu/packages/linux.scm
parent696b0a3246941f59e334fabbb06d7b69d9ef852c (diff)
gnu: strace: Allow readlink, readlinkat tests to pass.
Modify the invocation of strace's "readlink" and "readlinkat" tests to prevent them from failing due to an additional system call made by Guix's patched version of glibc. * gnu/packages/linux.scm (strace)[source]: Add patch. [arguments]<#:phases>: Do not disable the "readlink" test now that it can succeed. * gnu/packages/patches/strace-readlink-tests.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c838958f73..71da82d97d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2365,7 +2365,8 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
"/strace-" version ".tar.xz"))
(sha256
(base32
- "0mmns22bjjvakxj29si0x4dcylcgy26llpcimkb0llcxif439k2s"))))
+ "0mmns22bjjvakxj29si0x4dcylcgy26llpcimkb0llcxif439k2s"))
+ (patches (search-patches "strace-readlink-tests.patch"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -2378,10 +2379,6 @@ Zerofree requires the file system to be unmounted or mounted read-only.")
(add-after 'unpack 'disable-failing-tests
(lambda _
(substitute* "tests/Makefile.in"
- ;; XXX: This test fails because an extra readlink call is made
- ;; by the glibc when using the ld.so cache.
- (("readlink.gen.test[^:]") " ")
-
;; XXX: These hang forever even if the test time-out is
;; extended.
(("^\tstrace-DD?D?\\.test \\\\.*") "")